Ga naar inhoud
  • 0

linux boot niet na herordenen IDE devices


anoniem

Vraag

Ik heb een raar probleem. Ik wou mijn ide-devices op een andere volgorde hebben, om beide schijven apart te hebben aan een kabel, voor de snelheid van kopieren tussen de twee schijven. Ik had eerst de volgende indeling: primary master : hd, Archlinux (hda7) primary slave : hd, windows secondary master: cdrom secondary slave: writer ik heb nu de kabels van de primary slave en de secondary slave omgewisseld, ik bedoel dat ze andersom op dezelfde kabel zitten. dus nu is het primary master : hd, Archlinux (hda7) primary slave : writer secondary master: cdrom secondary slave: hd, windows Nu wil de primary master niet booten, ook niet als ik in het bootmenu van het bios die schijf selecteer. terwijl er niets is veranderd aan het MBR en de bootsector van de linux-partitie. De Windows schijf boot overigens wel gewoon. Heeft iemand een flauw idee waar dit door komt ? Ik heb ook geprobeerd om dan maar lilo te herinstalleren, weetikveel. maar het gekke is dat mijn archlinux cd die primary master niet kan mounten... hij staat wel in /dev/discs/disc0, maar daaronder zit alleen de directory /disc, wat het mbr voorstelt. De andere schijf (/dev/discs/disc1) heeft wel de partitie-subdirectories (/part1,2,3,5,6,7). Dus nog een vreemd geval, het zal er wel mee te maken hebben. Weet iemand een oplossing ?
Link naar reactie

4 antwoorden op deze vraag

Aanbevolen berichten

  • 0
Heb je goed op de jumper settings gelet? Het kan zijn dat de writer op CS stond en nu door een verkeerde locatie op de IDE kabel als master wordt herkend en de Arch-schijf als slave. Worden de devices volgens je BIOS idd in de door jouw opgegeven volgorde gedetecteerd? Het moet namelijk haast wel ergens fout zitten in de hardware config, aangezien het MBR niet van plek is veranderd en je de Arch-schijf ook niet vanaf CD kunt mounten.
Link naar reactie
  • 0
Het bios geeft die nieuwe volgorde idd aan, en de jumpers staan allemaal goed. De linux-schijf was master gejumperd, windows-schijf slave, de cdrom master en de writer slave. Ik heb toen de kabel van de writer in de windows-schijf gedaan en vice versa, zodat nog steeds op beide kanalen een master en een slave waren. Als dit niet zo was, had het BIOS er ook overgezeurd trouwens. het gekke is dus, dat Knoppix ze automatisch wel mount... maar daar kan ik overigens niet eventueel via een chrooted partitie lilo mee runnen want die kernel ondersteunt geen devfs... ik snap er dan ook niks van...
Link naar reactie
  • 0
Ik heb nu een andere configuratie: primary master : linux primary slave: writer secondary master: windows secondary slave : cdrom Nu zijn de hd's dus allebei master en de cd drives allebei slave. Nu is de linux schijf wel zichtbaar (gelukkig), maar de windows-schijf ' niet '. fdisk ziet wel de partites van /dev/hdc - of in archlinux - /dev/discs/disc1/disc, maar in /dev staat wel weer alleen hdc, en niet hdc1...9. ook in /dev/discs/disc1 staat alleen /disc oftewel het mbr. Vreemd he ? Ik moet overigens zeggen dat met hdparm -tT /dev/hdc soms (1 van de 4 keer) de volgende melding verschijnt: ---- Buffer I/O error on device hdc, logical block 0 read() failed: input/output error ---- "Badblocks /dev/hdc" geeft ook niks aan, ik heb hem niet helemaal uit laten gaan want het gaat toch om block 0... Ik weet niet wat het is, hij geeft deze fout ook alleen met de hdparm -d optie (dma ) op 1, de -c (32bit i/o) en -X70 (udma6) maken niet uit. Vervelend, want alleen met -d 1 werkt te schijf natuurlijk op acceptabele snelheid. Het lijkt mij nu zelf niet dat het een hardwarematig defect is, omdat het eerst andersom was, toen was de linux schijf 'onzichtbaar' op deze manier. Ik snap er geen ruk van... ik heb overigens op het primaire kanaal een 80 aderige kabel en op de secundaire nog zo'n 40 aderige... maar dat zal wel niet veel uit maken.
Link naar reactie
  • 0
[quote:13532d7dcb="musicom76"] [code:1:13532d7dcb] Buffer I/O error on device hdc, logical block 0 read() failed: input/output error [/code:1:13532d7dcb] ik heb overigens op het primaire kanaal een 80 aderige kabel en op de secundaire nog zo'n 40 aderige... maar dat zal wel niet veel uit maken. [/quote:13532d7dcb] Toen je writer en cdrom op je Secondary aangesloten zaten, was dat waarschijnlijk het geval. Maar nu je een harde schijf op de Secondary hebt aangesloten, ligt dit anders. Veel harde schijven zijn UDMA66 of hoger. Dan is een 80 aderige UDMA66/133 kabel vereist. Eventueel zou je ook nog kunnen proberen primary master : linux primary slave: cdrom secondary master: windows secondary slave : writer
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...