Ga naar inhoud
  • 0

Excel Hoe tel ik het aantal op dat een bepaalde tekst voorkomt in een rij cellen?


Mynameisbob

Vraag

Excel Ik wil het aantal cellen optellen waarin een bepaalde tekst voorkomt. De functies aantal.als en som.als weken niet goed, omdat deze ervan uitgaan dat de cel uitsluitende de genoemde tekst bevat. Mijn cellen bevatten bijvoorbeeld de tekst A, B, AB of is leeg. Ik wil het aantal keren weten, dat A voorkomt. Ik kan wel per cel controleren of bijv. A voorkomt (bijv. =ALS(ISFOUT(VIND.SPEC("A";B2:b10));"nee";"ja") , maar niet direct het aantal voor meerdere cellen. .
Link naar reactie

1 antwoord op deze vraag

Aanbevolen berichten

  • 0
Om het aantal keren dat een letter voorkomt in een rij, kolom of tabel voorkomt kun je de onderstaande formule gebruiken. =SUMPRODUCT(LEN(Table1)-LEN(SUBSTITUTE(Table1,E1,""))) Bovenstaande geeft je hoeveel maal de waarde die je in cel E1 (1 enkel teken, bijv a of A) hebt ingevuld voorkomt in de hele tabel wil je een rij of kolom of een bepaald bereik dan vervang je table1 voor het rij nummer bijv(2:2) of de kolom letter (B:B) of je bereik (A2:B10) Als je meerdere tekens wil laten opzoeken bijv hoe vaak het woordje straat in je tabel, rij of kolom voorkomt dan kan onderstaande formule gebruikt worden: =COUNTIF(Table1,"*"&E1&"*") waarbij dan in cel E1 de op te zoeken waarde word ingegeven. natuurlijkis ook hier Table1 weer te vervangen voor rij, kolom of bereik
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...