Ga naar inhoud
  • 0

[Mandrake 9.2] Netwerkkaart niet gedetecteerd


anoniem

Vraag

Hallo, ik heb gisteren Mandrake 9.2 geïnstalleerd op mijn computer. Dat ging prima, alleen nu werkt de netwerkkaart niet. Daarvoor had ik even gewerkt met de live-cd versie Morphix, en daar herkende hij mijn netwerkkaart wel, maar de audio (beide op het moederboard geïntegreerd) niet, terwijl hij die in Mandrake wel gelijk herkent. Mijn moederboard is een Soltek 75FRN2-L met de Nvidia Nforce chipset. Van de website van Nvidia heb ik de nieuwste Linux-drivers gedownload, maar dat hielp niet. Vervolgens heb ik de Ethernet HowTo doorgenomen, waarin mij aangeraden werd te kijken of hij bij het opstarten ergens de eth0 wou laden. Dat staat er nergens tussen. Blijkbaar herkent hij mijn netwerkkaart dus niet. Wat moet ik doen?
Link naar reactie

9 antwoorden op deze vraag

Aanbevolen berichten

  • 0
Ik was op het geniale idee gekomen om het eens te proberen met een andere netwerkkaart erin. Ik had er toch nog eentje liggen, een Realtek, dus die erin gedouwd en gelijk in 1 keer herkend en geconfigureerd, dus dat werkt. Ik zit nu wel op 10 mbit ipv 100, maar dat maakt niet zoveel uit. Wat lastiger is is dat als deze computer in Windows gebruikt wordt de kabel omgezet moet worden. Wat ik wel vreemd vind is dat Harddrake2 wel de nForce MCP Networking Adapter ziet, maar ik kom niet tot configureren.
Link naar reactie
  • 0
[quote:ca28d8abde="wdb"]Mijn moederboard is een Soltek 75FRN2-L met de Nvidia Nforce chipset. Van de website van Nvidia heb ik de nieuwste Linux-drivers gedownload, maar dat hielp niet. [/quote:ca28d8abde] Bedoel je deze Linux-drivers? http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.tar.gz [quote:ca28d8abde="wdb"]Vervolgens heb ik de Ethernet HowTo doorgenomen,[/quote:ca28d8abde] Welke Ethernet howto? Ik neem aan dat je die tar.gz drivers hebt uitgepakt met [code:1:ca28d8abde] tar -xzvf naam.tar.gz [/code:1:ca28d8abde][Enter] en [code:1:ca28d8abde] cd nforce [/code:1:ca28d8abde][Enter] en [code:1:ca28d8abde] make [/code:1:ca28d8abde][Enter] Indien je een foutmelding kreeg, had je de volgende pakketten al geïnstalleerd? [code:1:ca28d8abde] make gcc binutils glibc-devel kernel-source [/code:1:ca28d8abde] En daarna als root of super user [code:1:ca28d8abde] make install [/code:1:ca28d8abde][Enter] En had je deze regel al toegevoegd aan /etc/modules.conf [code:1:ca28d8abde] alias eth0 nvnet [/code:1:ca28d8abde]
Link naar reactie
  • 0
[quote:36241ebeea]Bedoel je deze Linux-drivers? http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.tar.gz[/quote:36241ebeea] nee, via [url]www.nvidia.com/linux[/url] heb ik deze [url=http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.mdk91up_2.4.21_0.13.athlon.rpm]rpm[/url] gedownload, en de readme gevolgd die op de website stond. Daar zeiden ze dat je gewoon moest installeren en verder gebeurt alles automatisch. In mijn modules.conf stond dan ook al "alias eth0 nvnet". De HowTo die ik gevolgd heb staat hier: [url]http://metalab.unc.edu/mdw/HOWTO/Ethernet-HOWTO.html[/url] BTW, waarom wisselt Linux ] en [ om, die staan precies andersom dan mijn toetsenbord aangeeft, erg irritant! (hij staat wel op zijn Nederlands ingesteld, andere tekens zijn prima
Link naar reactie
  • 0
Dus je hebt een rpm die voor Mandrake 9.1 bedoelt is, geïnstalleerd in Mandrake 9.2. Ik denk dat je dan beter de source drivers kunt proberen. Wat voor een foutmelding kreeg je? Wat is de output van [code:1:aaaed1903a] dmesg | grep eth [/code:1:aaaed1903a][Enter] [quote:aaaed1903a="wdb"]BTW, waarom wisselt Linux ] en [ om, die staan precies andersom dan mijn toetsenbord aangeeft, [/quote:aaaed1903a] Waarschijnlijk kun je deze vraag beter in een nieuw topic stellen. Waarin je meld wat voor een toetsenbord je hebt. Eventueel meld je waar bij jouw de @ is. Bijvoorbeeld boven de 2.
Link naar reactie
  • 0
[quote="jolo"]Dus je hebt een rpm die voor Mandrake 9.1 bedoelt is, geïnstalleerd in Mandrake 9.2. Ik denk dat je dan beter de source drivers kunt proberen. Wat voor een foutmelding kreeg je? Wat is de output van [code:1:5f9fb01550] dmesg | grep eth [/code:1:5f9fb01550][Enter] Ik zal proberen de source drivers te installeren. Ik kreeg geen foutmeldingen bij het installeren van de Mandrake 9.1-drivers. het resultaat van dmesg | grep eth is: eth0: RealTek RTL-8029 found at 0xa000, IRQ 5, 52:54:05:C4:4D:90. NETDEV WATCHDOG: eth0: transmit timed out eth0: Tx timed out, cable problem? TSR=0x16, ISR=0x0, t=22. NETDEV WATCHDOG: eth0: transmit timed out eth0: Tx timed out, cable problem? TSR=0x16, ISR=0x0, t=25. NETDEV WATCHDOG: eth0: transmit timed out eth0: Tx timed out, cable problem? TSR=0x16, ISR=0x0, t=25. maar eth0 is de pci-kaart die ik er bijgehangen heb die dus wel werkt. de kabel zit er wel in (ik zit er nu zelfs over te internetten), maar ook op de Windows-pc hiernaast geeft hij die foutmelding :-?
Link naar reactie
  • 0
Toen ik die source-drivers probeerde, kreeg ik eerst problemen omdat ik dus niet alle benodigde pakketen had. die dan geïnstalleerd (+ alles wat er ook maar een beetje op leek) en dan weer make gedaan, toen kwam hij verder dan de vorige keer maar hij gaf nu nog veel meer foutmeldingen. ik ben zo dom geweest om die niet op te schrijven... Overigens toen ik daarvoor probeerde de rpm te deïnstalleren (zoals het in de handleiding stond: example% cd <directory with rpm file> example% su Password: ****** example# rpm -e nforce<package name>-1.0-1.rpm) gaf hij aan dat ze niet geïnstalleerd waren. Maar goed, nadat ik dit gedaan had plus nog wat gespeeld had met het systeem werkte mijn geluid, netwerk en cdrom niet meer. Geluid kreeg ik weer aan de gang maar de andere 2 niet, dus ik heb het maar opnieuw geïnstalleerd. Ik ga zo proberen de source drivers te installeren.
Link naar reactie
  • 0
Hij geeft nog steeds dezelfde fout, dit keer heb ik het wel: [quote:3476758464] make -C nvnet make[1]: Entering directory `/home/wouter/nforce/nforce/nvnet' cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/usr/src/linux-2.4.22/include nvnet.c In file included from /usr/include/linux/prefetch.h:13, from /usr/include/linux/list.h:6, from /usr/include/linux/module.h:11, from nvnet.h:20, from nvnet.c:21: /usr/include/asm/processor.h:55: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/asm/processor.h:55: error: requested alignment is not a constant In file included from /usr/include/linux/module.h:20, from nvnet.h:20, from nvnet.c:21: /usr/include/linux/modversions.h:1:2: #error "=======================================================" /usr/include/linux/modversions.h:2:2: #error "You should not include /usr/include/{linux,asm}/ header" /usr/include/linux/modversions.h:3:2: #error "files directly for the compilation of kernel modules." /usr/include/linux/modversions.h:4:2: #error "" /usr/include/linux/modversions.h:5:2: #error "glibc now uses kernel header files from a well-defined" /usr/include/linux/modversions.h:6:2: #error "working kernel version (as recommended by Linus Torvalds)" /usr/include/linux/modversions.h:7:2: #error "These files are glibc internal and may not match the" /usr/include/linux/modversions.h:8:2: #error "currently running kernel. They should only be" /usr/include/linux/modversions.h:9:2: #error "included via other system header files - user space" /usr/include/linux/modversions.h:10:2: #error "programs should not directly include <linux/*.h> or" /usr/include/linux/modversions.h:11:2: #error "<asm/*.h> as well." /usr/include/linux/modversions.h:12:2: #error "" /usr/include/linux/modversions.h:13:2: #error "To build kernel modules please do the following:" /usr/include/linux/modversions.h:14:2: #error "" /usr/include/linux/modversions.h:15:2: #error " o Have the kernel sources installed" /usr/include/linux/modversions.h:16:2: #error "" /usr/include/linux/modversions.h:17:2: #error " o Make sure that the symbolic link" /usr/include/linux/modversions.h:18:2: #error " /lib/modules/`uname -r`/build exists and points to" /usr/include/linux/modversions.h:19:2: #error " the matching kernel source directory" /usr/include/linux/modversions.h:20:2: #error "" /usr/include/linux/modversions.h:21:2: #error " o Now copy /boot/vmlinuz.version.h to" /usr/include/linux/modversions.h:22:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h" /usr/include/linux/modversions.h:23:2: #error "" /usr/include/linux/modversions.h:24:2: #error " o When compiling, make sure to use the following" /usr/include/linux/modversions.h:25:2: #error " compiler option to use the correct include files:" /usr/include/linux/modversions.h:26:2: #error "" /usr/include/linux/modversions.h:27:2: #error " -I/lib/modules/`uname -r`/build/include" /usr/include/linux/modversions.h:28:2: #error "" /usr/include/linux/modversions.h:29:2: #error " instead of" /usr/include/linux/modversions.h:30:2: #error "" /usr/include/linux/modversions.h:31:2: #error " -I/usr/include/linux" /usr/include/linux/modversions.h:32:2: #error "" /usr/include/linux/modversions.h:33:2: #error " Please adjust the Makefile accordingly." /usr/include/linux/modversions.h:34:2: #error "=======================================================" In file included from /usr/include/linux/module.h:297, from nvnet.h:20, from nvnet.c:21: /usr/include/linux/version.h:2:2: #error "=======================================================" /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header" /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules." /usr/include/linux/version.h:5:2: #error "" /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined" /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)" /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the" /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be" /usr/include/linux/version.h:10:2: #error "included via other system header files - user space" /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or" /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well." /usr/include/linux/version.h:13:2: #error "" /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:" /usr/include/linux/version.h:15:2: #error "" /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed" /usr/include/linux/version.h:17:2: #error "" /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link" /usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to" /usr/include/linux/version.h:20:2: #error " the matching kernel source directory" /usr/include/linux/version.h:21:2: #error "" /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to" /usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h" /usr/include/linux/version.h:24:2: #error "" /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following" /usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:" /usr/include/linux/version.h:27:2: #error "" /usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include" /usr/include/linux/version.h:29:2: #error "" /usr/include/linux/version.h:30:2: #error " instead of" /usr/include/linux/version.h:31:2: #error "" /usr/include/linux/version.h:32:2: #error " -I/usr/include/linux" /usr/include/linux/version.h:33:2: #error "" /usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly." /usr/include/linux/version.h:35:2: #error "=======================================================" In file included from nvnet.h:20, from nvnet.c:21: /usr/include/linux/module.h:299: error: syntax error before "UTS_RELEASE" In file included from /usr/include/linux/mm.h:12, from /usr/include/linux/slab.h:14, from nvnet.h:29, from nvnet.c:21: /usr/include/linux/mmzone.h:44: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/linux/mmzone.h:44: error: requested alignment is not a constant In file included from /usr/include/asm/hardirq.h:6, from /usr/include/linux/interrupt.h:46, from nvnet.h:30, from nvnet.c:21: /usr/include/linux/irq.h:65: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/linux/irq.h:65: error: requested alignment is not a constant In file included from /usr/include/linux/interrupt.h:46, from nvnet.h:30, from nvnet.c:21: /usr/include/asm/hardirq.h:16: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/asm/hardirq.h:16: error: requested alignment is not a constant In file included from nvnet.h:30, from nvnet.c:21: /usr/include/linux/interrupt.h:129: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/linux/interrupt.h:129: error: requested alignment is not a constant In file included from nvnet.h:31, from nvnet.c:21: /usr/include/linux/version.h:2:2: #error "=======================================================" /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header" /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules." /usr/include/linux/version.h:5:2: #error "" /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined" /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)" /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the" /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be" /usr/include/linux/version.h:10:2: #error "included via other system header files - user space" /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or" /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well." /usr/include/linux/version.h:13:2: #error "" /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:" /usr/include/linux/version.h:15:2: #error "" /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed" /usr/include/linux/version.h:17:2: #error "" /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link" /usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to" /usr/include/linux/version.h:20:2: #error " the matching kernel source directory" /usr/include/linux/version.h:21:2: #error "" /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to" /usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h" /usr/include/linux/version.h:24:2: #error "" /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following" /usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:" /usr/include/linux/version.h:27:2: #error "" /usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include" /usr/include/linux/version.h:29:2: #error "" /usr/include/linux/version.h:30:2: #error " instead of" /usr/include/linux/version.h:31:2: #error "" /usr/include/linux/version.h:32:2: #error " -I/usr/include/linux" /usr/include/linux/version.h:33:2: #error "" /usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly." /usr/include/linux/version.h:35:2: #error "=======================================================" In file included from nvnet.h:35, from nvnet.c:21: /usr/include/linux/netdevice.h:165: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/linux/netdevice.h:165: error: requested alignment is not a constant In file included from nvnet.h:35, from nvnet.c:21: /usr/include/linux/netdevice.h:517: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function) /usr/include/linux/netdevice.h:517: error: requested alignment is not a constant nvnet.c:40:41: missing binary operator before token "(" nvnet.c:1284:41: missing binary operator before token "(" make[1]: *** [nvnet.o] Fout 1 make[1]: Leaving directory `/home/wouter/nforce/nforce/nvnet' make: *** [nvnet_make] Fout 2 [/quote:3476758464] maar dit keer werkte alles verder wel. (andere netwerkkaart, geluid, cdrom)
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...