Ga naar inhoud
  • 0

apt-get get not


anoniem

Vraag

Hallo, Heb problemen met update. Meldingen als 'kon..niet opvragen' en 'ophalen is mislukt, genegeerd of er zijn oudere versies van gebruikt' Dus naar 'sources.list' gekeken. En daarmee is hiet niet eenvoudiger geworden. Kijk eens hier welke adviezen en zoal zijn: Tekst voor /etc/apt/sources.list Debian Linux (Etch) van www.apt-get.eu/ deb http://debian.apt-get.eu/debian/ etch main deb http://debian.apt-get.eu/debian/ etch contrib deb http://debian.apt-get.eu/debian/ etch non-free deb http://security.debian.apt-get.eu/security/ etch/updates main Van: www.debian.org/security Uw Debian systeem veilig houden Om recente beveiligingsberichten van Debian te ontvangen kunt u zich aanmelden op de debian-security-announce mailinglijst. U kunt apt gebruiken om de recente beveiligingsupdates te ontvangen. Dit is mogelijk door een regel als deb http://security.debian.org/ stable/updates main contrib non-free in uw /etc/apt/sources.list bestand op te nemen. Van: www.debian.org/releases/stable/errata.nl.html: Het Debian-beveiligingsteam werkt pakketten bij in de stabiele release wanneer ze problemen gerelateerd met de beveiliging hebben geïdentificeerd. Bekijk de beveiligingspagina's voor informatie over onderkende beveiligingsproblemen in etch. Als u APT gebruikt, voeg dan de volgende regel toe aan /etc/apt/sources.list om toegang te hebben tot de laatste beveiligingsupdates: deb http://security.debian.org/ etch/updates main contrib non-free Voer daarna apt-get update uit, gevolgd door apt-get upgrade. Van Computertotaal, M.V. Wasstein Geplaatst: zo aug 19, 2007 8:26 pm Onderwerp: Code: # deb cdrom:[Debian GNU/Linux testing _Etch_ - Official Snapshot i386 NETINST Binary-1 20070315-20:52]/ etch contrib main deb http://ftp.debian.nl/debian/ etch main contrib non-free deb-src http://ftp.debian.nl/debian/ etch main contrib non-free deb http://security.debian.org/ etch/updates main contrib deb-src http://security.debian.org/ etch/updates main contrib Pas je sources.list aan zodattie er zo uit ziet, dan doe je Code: apt-get update && apt-get dist-upgrade Hierna zal je server erg lang gaan kauwen op de upgrade, dus haal de server tijdelijk off-line (alleen Apache dan, dus de pagina's zijn tijdelijk niet beschikbaar) zodattie in alle rust en ongestoord kan kauwen Reboot in de nieuwe kernel (Etch default: 2.6.18, Sarge heeft max 2.6.8 ) Hierna kun je ClamAV installeren. Weet iemand me te vertellen wat de juiste tekst is voor debian etch 4.0 r0. Offe....een nieuwe versie installeren ???? Al vast bedankt opamax
Link naar reactie

Aanbevolen berichten

  • 0
[quote:8b0e5cd4de="opamax"]Heb problemen met update. Meldingen als 'kon..niet opvragen' en 'ophalen is mislukt, genegeerd of er zijn oudere versies van gebruikt' [/quote:8b0e5cd4de] En je bent er zeker van dat je internet verbinding (nog) wel werkt onder Debian Etch? [quote:8b0e5cd4de="opamax"]Dus naar 'sources.list' gekeken. [/quote:8b0e5cd4de] Mogelijk dat je de originele sources.list nog kunt terugzetten. Check verder op Wikipedia deze info over [url=http://en.wikipedia.org/wiki/Debian#Branches.2C_official_and__unofficial_repositories]Branches, official and unofficial repositories.[/url]
Link naar reactie
  • 0
[quote:e7afcec3d6="opamax"]2.Heb in sources.list alles afgehekt en ben nu bezig regel voor regel te testen. Dat kan toch geen kwaad ?[/quote:e7afcec3d6] Dat zou je inderdaad kunnen doen. Kan inderdaad geen kwaad. Je zou kunnen beginnen met het testen van de main regels. [quote:e7afcec3d6="opamax"]Ben nu bezig met nieuwe installatie( van 4.0 r.0). Even aanzien hoe het straks zal zijn. [/quote:e7afcec3d6] Is alleen nodig indien je oude installatie volledig in de soep is gedraaid. [quote:e7afcec3d6="opamax"]Hoe kan ik vanaf de command line het "Hoofdmenu Debian Installatieprogramma" bereiken ?[/quote:e7afcec3d6] Dat weet ik niet zo uit het hoofd. Het is alweer een tijdje geleden, dat ik zelf debian had geïnstalleerd. Je zou de [url=http://www.debian.org/releases/stable/installmanual]Debian GNU/Linux 4.0 – Installatiehandleiding[/url] kunnen checken.
Link naar reactie
  • 0
Dus opnieuw geinstalleerd. Dus ook een nieuwe sources.list. Dat heeft standaard 4 regels. Regel 2 t/m 4 afgehekt en gedaan[code:1:87570c5a45]apt-get update[/code:1:87570c5a45] wat zonder foutmelding word uitgevoerd. Daarna resp regels 2 t/m 'onthekt' en krijg alleen van de laatste regel[code:1:87570c5a45] deb-src http://security.debian.org/ etch/updates main contrib[/code:1:87570c5a45] en dus na apt-get update de melding[code:1:87570c5a45]Fout bij het lezen van de server[/code:1:87570c5a45] en iets verder[code:1:87570c5a45]E: Ophalen van sommige indexbestanden is mislukt, deze zijn of genegeerd, of er zijn oudere versies van gebruikt[/code:1:87570c5a45]Ik denk dat hiermee wel te leven valt en ga dus verder. Hartelijk dank voor meedenken. opamax
Link naar reactie
  • 0
Het lijkt me nog niet in orde. Had je tijdens de Debian installatie wel met succes je netwerkkaart kunnen configureren? En had je tijdens de Debian installatie het Pakketbeheer geconfigureerd? Dus bijvoorbeeld Land van Debian-archief-spiegelserver Nederland ftp.debian.nl Ik kwam bij mijn oude cd's een oude Debian 4.0 test versie tegen. Dus niet r.0 maar een bèta versie. Als ik tijdens de installatie die Nederlandse server selecteer, dan werkt die apt-get update commando als superuser wel goed. Die eindigt dan met de melding [code:1:c4eaf588d5] Pakketlijsten worden ingelezen... Klaar. [/code:1:c4eaf588d5]
Link naar reactie
  • 0
Er is inderdaad iets niet goed. WEL met de kaart, want er is al veel opgehaald, maar: 'less' werkt niet. Kan een file WEL editen. maar niet lezen, en heb MYSQL geinstalleerd. Geen foutnelding, maar kan /etc/mysql/my.cnf niet wijzigen. Sterker; de map /etc/mysql is zelfs niet te vinden. Heb -anders dan advies in Howtoforge- de installatie gesplitst, dus eerst mysql-server en daarna de rest. Lijkt dan goed te gaan. Echter bij de restart krijg ik:[code:1:a76797fd8d]Stopping MySQL database server: mysqld Starting MySQL database server: mysqld Checking for corrupt, not cleanly closed and upgrade needing tables...[/code:1:a76797fd8d] dus nog een keer update en upgrade gedaan, maar die melding blijft gelijk. Echter na de update zie ik de melding:[code:1:a76797fd8d]E: Ophalen van sommige indexbestanden is mislukt, deze zijn of genegeerd, of er zijn oudere versies van gebruikt.[/code:1:a76797fd8d] Deze meldingen lijken me niet te leiden naar een onberispelijk werkende server. Nieuwe versie proberen ? Andere distri kiezen ?
Link naar reactie
  • 0
Over die MySQL en die /etc/mysql/my.cnf staat wel iets over op http://www.aboutdebian.com/database.htm Werkt die apt-get update nu dan wel? [quote:e56428baa6="opamax"]Nieuwe versie proberen ?[/quote:e56428baa6] Debian 4.0 is toch al de nieuwste versie. [quote:e56428baa6="opamax"]Andere distri kiezen ?[/quote:e56428baa6] Eventueel Ubuntu 8.04. Of heb je een goede reden om Debian te kiezen? Om Debian te goed te kunnen configureren, is wel wat meer ervaring voor nodig, dan bij Ubuntu. Check onder andere op het AllesLinux forum deze topic over het onderwerp [url=http://www.alleslinux.com/forum/viewtopic.php?start=0&t=5447]Ubuntu vs. Debian.[/url]
Link naar reactie
  • 0
Debian ? Ben ik zomaar bij aangeland. Ben met Ubuntu bezig geweest, weet niet waarom ik daarmee ben gestopt. Mijn -nieuwe- vraag nu: Waarom zou ik Debian verlaten ? Is dat niet meer zo "in" ? De door jou aangehaalde discussie brengt ook geen duidelijk oordeel. Waar ik naar toe wil: Een eigen web (etc-)server. Klinkt eigenwijs, maar ondanks de vele en goedkope hosting-aanbiedingen heb ik iets van zelf, ZELF- doen. Stom hè ? Debian zou goed zijn voor een stabiele server. Moet/kan ik dat nog aanhangen ?
Link naar reactie
  • 0
[quote:884d7b2370="opamax"]Ben met Ubuntu bezig geweest, weet niet waarom ik daarmee ben gestopt. [/quote:884d7b2370] Dat was toch in dat topic http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=175117&highlight=debian en Webmin over Debian http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=181211&highlight=debian [quote:884d7b2370="opamax"]Mijn -nieuwe- vraag nu: Waarom zou ik Debian verlaten ? Is dat niet meer zo "in" ? [/quote:884d7b2370] Hoeft niet. In Linux heb je altijd vrije keuze. Mogelijk dat er met Debian iets meer documentatie zal moeten worden gelezen. Wellicht staat er iets bruikbaar op NedLinux in deze topic over onderwerp [url=http://forum.nedlinux.nl/viewtopic.php?id=20780]Complete Debian Linux Server Setup Tutorials.[/url]
Link naar reactie
  • 0
[quote:b1fc7a5ba0="jolo"]Debian 4.0 is toch al de nieuwste versie.[/quote:b1fc7a5ba0] Om precies te zijn is dat [url=http://www.debian.org/releases/etch/debian-installer/]Debian GNU/Linux 4.0r3.[/url] Als je echt de nieuwste Debian versie wilt proberen, zou je Debian [url=http://www.debian.org/devel/debian-installer/]lenny beta2[/url] kunnen proberen. Deze heeft zelfs een grafische installatieprocedure. Het downloaden van alleen CD1 is voldoende. Of eventueel de netinstal CD. [quote:b1fc7a5ba0="opamax"]Een eigen web (etc-)server.[/quote:b1fc7a5ba0] Overigens raad ik aan die webserver alleen voor je lokale PC's te gebruiken. Dus achter de router, zodat deze vanaf het internet niet is te bereiken.
Link naar reactie
  • 0
[quote:69b948c2e9="opamax"] Niet aan internet ?[/quote:69b948c2e9] Ik bedoel dat je wel op het internet kan vanaf Debian. Maar dan in één richting. Dus dat je PC server niet te bereiken zou moeten zijn vanaf het internet. Ten eerste is zoiets voor gevorderden. Als deze niet goed is beveiligd, zou deze door hackers worden misbruikt om te spammen. Daarom staan de meeste providers van particulieren internet accounts een eigen (email/web)server, die vanaf het internet te bereiken is niet toe. En hebben mogelijk poort 25 en 80 gesloten.
Link naar reactie
  • 0
[code:1:bb4ce9c4fb]deb-src http://security.debian.org/ etch/updates main contrib[/code:1:bb4ce9c4fb] Deze heb je niet nodig, tenzij je zelf in de code wilt foeteren/patchen/compileren.. elke regel die begint met 'deb-src' dus. ipv 'etch' kan je ook stable zetten, zo ga je altijd mee naar de huidige versie als debian een release doet. testing (nu = 'lenny') is dan iets 'minder' stabiel, tis te zeggen minder getest, maar meer dan behoorlijk stabiel. en unstable of (altijd 'sid') is kan af en toe eens foutgaan, en dan moet je wachten tot ze het oplossen. je hebt er wel altijd het nieuwste van het nieuwste voor... Stable versions duren nogal lang.. Ikzelf gebruik lenny(testing). Debian adviseert om de namen te gebruiken, zodat je meer 'bewust' bent van de versie, maar dit hoeft echt niet. Toch niet voor thuisgebruikers. Ik vind het moeilijker om van Etch naar lenny te gaan, na bv x maand, dan overvloeien van release naar release via stable.. Groeten.
Link naar reactie
  • 0
DEB-SRC heb je idd niet nodig. (daarom staan ze default in commentaar) Etch of stable is aan jou om te beslissen. Het is hetzelfde maw. Behalve wanneer Debian beslist dat lenny(testing) stabiel genoeg is om te releasen àls stable. Als de computer een ouwe bak is die enkel dienst doet als webserver en dergelijke zet je etch. Is de PC ook je hoofdcomputer zet je stable. Zodat je zo nu en dan eens nieuwe versies binnenkrijgt als gnome enzovoort.. MAIN CONTRIB NON-FREE moet je erbij zetten(zeker main). Zonder deze heeft apt-update geen zin. Dit zijn de dirs waar hij zijn packages haalt. Main = Puur debian onderhouden/gemod. (ALLES FREE, dus geen prop drivers ook niet.) Contrib = Door externen onderhouden en ontwikkeld, behalve gepackage'd door debian. (ALLES FREE) Non-free = spreekt voor zich.(niet onderhouden/ontwikkeld door debian) Wil je codecs voor gesloten formaten moet je ook een kijkje nemen op http://www.debian-multimedia.org en ook aan je apt sources.list toevoegen Groeten.
Link naar reactie
  • 0
[quote:1301275b73="opamax"]Heb nu Debian 4.0 r0 geinstalleerd. Met apt-get update zie ik regeld met GERAAKT en GENEGEERD. [/quote:1301275b73] De eerste melding geeft aan, dat die regel in orde is. Bij de tweede melding, kan er iets mis zijn. Hoe luid de volledige apt-get update output? Je zou eventueel een andere apt-get mirror kunnen nemen. Check voor info hierover deze [url=http://www.debian.org/doc/manuals/apt-howto/ch-basico.en.html#s-sources.list]apt howto.[/url]
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...