Ga naar inhoud
  • 0

syslog in FC4 logged niets (meer)


anoniem

Vraag

De laatste entry's in /var/log/messages Jun 21 21:07:32 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team Jun 21 21:07:32 localhost kernel: ip_conntrack version 2.1 (1527 buckets, 12216 max) - 272 bytes per conntrack Jun 21 21:07:32 localhost kernel: Kernel logging (proc) stopped. Jun 21 21:07:32 localhost kernel: Kernel log daemon terminating. Jun 21 21:07:34 localhost exiting on signal 15 sindsdien wordt er niks meer gelogd, ook niet in /var/log/secure. Als ik de status van syslog service bekijk, is syslogd en klogd gestart, ook al een restart gedaan van syslog, echter geen verschil. Iemand enig idee wat ik verder nog kan doen?
Link naar reactie

Aanbevolen berichten

  • 0
Heb al een restart geprobeerd, hij herstart uiteraard wel, echter er wordt niks gelogd....De enige hacker in de buurt ben ik :lol: (door gebrek aan kennis :wink: ) het enige wat me tot nu toe gelukt is, is syslog starten met syslogd -d , de debug messages worden wel in de messages-log toegevoegd...
Link naar reactie
  • 0
Ok, ben al iets verder, als ik de syslog service stop en vervolgens syslogd en klogd opstart (dus zonder opties), dan gaat het goed....(tip kwam van internet), vervolgens moest ik volgens de site /etc/rc.conf aanpassen zodat bij een reboot syslogd en klogd zonder opties worden opgestart, echter deze file kan ik nergens vinden, welke zou ik hiervoor aan moeten passen?
Link naar reactie
  • 0
[quote:cb18a651af="MrLeeJohn"]Welke distro heb je? Kan ook /etc/rc.d/rc.conf of zoiets zijn.[/quote:cb18a651af] FC4 (Fedora Core 4). Ben er wel achter dat de oorzaak waarschijnlijk Webmin is/was, de laatste entry is vlak voordat ik bandwhidht-monitoring aanschakelde. Uiteraard heb ik die al gestopt en zelfs de webminservice helemaal gestopt, geen success.
Link naar reactie
  • 0
[quote:19aa0b2d8a="MrLeeJohn"]Wat je zoekt zijn de files in /etc/rc.d/init.d waarschijnlijk.[/quote:19aa0b2d8a] Tja, de syslog config zegt daar: [code:1:19aa0b2d8a] if [ -f /etc/sysconfig/syslog ] ; then . /etc/sysconfig/syslog else SYSLOGD_OPTIONS="-m 0" KLOGD_OPTIONS="-2" [/code:1:19aa0b2d8a] Als ik de options verwijder in /etc/sysconfig/syslog en de else options, en vervolgens reboot, dan werkt het nog steeds niet, ik kan alleen niet zien of syslog dan wel of niet met bepaalde opties draait.
Link naar reactie
  • 0
[quote:a6ff1f6a3f="MrLeeJohn"]Heb je er wat aan om dit gewoon via het commando "setup" (in een terminal-scherm als root) te doen met de optie runlevel-editor?[/quote:a6ff1f6a3f] Als ik setup run, kom ik in een tekstgebaseerd configuratie hulpmiddel, hoe geef ik de optie runlevel-editor mee?
Link naar reactie
  • 0
[quote:fad8d39546="MrLeeJohn"]Uuh... heet daar idd "system services". Btw... een beetje zelf googlen is ook erg leerzaam hoor :wink:[/quote:fad8d39546] Uiteraard, zover was ik ook al, maar het enige wat je kan doen bij system services is het al dan niet opstarten bij een boot, verdere opties meegeven of weglaten kan daar niet. Uiteraard google ik, staat de laatste dagen bijna continu aan met zoekopdrachten, alleen hier kom ik ffies niet verder mee.
Link naar reactie
  • 0
[quote:2987413db9="MrLeeJohn"]Weet je wat.... zet de services via setup uit en start ze manual via /etc/rc.d/rc.local. Dat doe ik met apache ook vaak. Da's een goed idee he?[/quote:2987413db9] :roll: Ik heb geen idee :wink: , als jij zegt dat dat kan, geloof ik je. Ik zal het proberen en laat het weten.....
Link naar reactie
  • 0
Wazig...kheb ze uitgeschakeld via chkconfig en in rc.local geplaatst, ze worden dan ook netjes gestart bij een reboot, echter.......er wordt niks gelogd WHHAAAAAA!!!!!!!....., nouja, dan er maar gewoon om denken dat ik ze zlf ffies met de hand opstart na een eventuele reboot (schijnt toch een zeldzaamheid te zijn bij Linux :wink: ) Iig bedankt voor het meedenken.
Link naar reactie
  • 0
/etc/sysconfig/syslog [code:1:d364d6c48d] # Options to syslogd # -m 0 disables 'MARK' messages. # -r enables logging from remote machines # -x disables DNS lookups on messages recieved with -r # See syslogd(8) for more details SYSLOGD_OPTIONS="-m 0" # Options to klogd # -2 prints all kernel oops messages twice; once for klogd to decode, and # once for processing with 'ksymoops' # -x disables all klogd processing of oops messages entirely # See klogd(8) for more details KLOGD_OPTIONS="-x" [/code:1:d364d6c48d] /etc/syslog.conf [code:1:d364d6c48d] # Log all kernel messages to the console. # Logging much else clutters up the screen. #kern.* /dev/console # Log anything (except mail) of level info or higher. # Don't log private authentication messages! *.info;mail.none;authpriv.none;cron.none /var/log/messages # The authpriv file has restricted access. authpriv.* /var/log/secure # Log all the mail messages in one place. mail.* -/var/log/maillog # Log cron stuff cron.* /var/log/cron # Everybody gets emergency messages *.emerg * # Save news errors of level crit and higher in a special file. uucp,news.crit /var/log/spooler # Save boot messages also to boot.log local7.* /var/log/boot.log [/code:1:d364d6c48d]
Link naar reactie

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...