Ga naar inhoud
  • 0

nieuwe Maxtor 40 GB disk in oud systeem


anoniem

Vraag

Om mijn nostalgische Cyrix (=~ P2) computer met bijbehorend zeer oud abit mobo te upgraden, heb ik onlangs een 40 GB ATA Maxtor harddisk aangeschaft. Hij doet het alleen als ik een jumper omzet, waardoor er nog maar 32 GB beschikbaar blijft. Nergens een flash-update te vinden voor het BIOS. Onlangs kwam ik er achter dat er een proggie Maxblast3.exe bestaat op de Maxtor site, waardoor de volle 40 GB beschikbaar komt, maar dan wel onder MsWindows (alle smaken) en vfat & NTSF. De vraag is of er onder Linux (Slackware in mijn geval) ook iets dergelijks bestaat. (proggie of kernel-patch.)Let wel dat dit de /dev/hdb schijf wordt. Een andere (8 GB) wordt /dev/hda met MsWindows. Via lilo moet er geboot worden. Een proggie waarmee alleen maar een data-schijf opgeleukt wordt heb ik dus niets aan. Weet niet goed hoe hiernaar te zoeken in Google.
Link naar reactie

10 antwoorden op deze vraag

Aanbevolen berichten

  • 0
[quote:009775015e="Pinky & The Brain"]Je kunt ook altijd proberen om de HD's in het bios op none te zetten (!).[/quote:009775015e]Ik heb bij een oude Pentium I MMX computer hetzelfde gedaan, daar zitten nu o.a. een schijf van 120GB en een van 160GB in, zonder enige problemen. Gewoon uit de bios halen heeft voor mij perfect geholpen. - Bas
Link naar reactie
  • 0
Ik heb een 20gb schijf zitten in een pentium1 waarbij het bios maar tot 8gb aankan. Het bios detecteert de schijf gewoon als 8gb, en kan linux booten van die schijf (wel ervoor gezorgd dat de boot partitie onder de 8gb grens blijft), en linux zelf kan dan de volledige schijf gebruiken. Ik heb zo'n flauw vermoeden dat het bij u op dezelfde manier gaat werken als je die jumper gewoon laat aanstaan en de schijf mooi als 32gb laat detecteren door het bios.
Link naar reactie
  • 0
Ik heb hier inmiddels ook een harde schijf aangeschaft, die groter is dan mijn asus cuv4x-d moederbord kan detecteren. Daar zat een 80 GB harde schijf in die correct werd herkent door de BIOS. De aangeschafte 200 GB harde schijf, die ik eerst testte op de Secondary ide controlller, werd door de BIOS herkent als 8 GB. Zoals maximilaan al aangaf, blijkt het inderdaad te kloppen dat Linux (en ook Windows XP) de harde schijf volledig ziet. De harde schijf hoefde daarvoor niet uit de BIOS gehaald te worden. In tegenstelling tot de topic starten, heb ik de 200 GB harde schijf daarna geïnstalleerd als Primary Master. Bij mij gaf GRUB (SuSE 9.2) een error [code:1:956a7f9038] grub loading stage 1.5 GRUB Loading, please wait... Error 18 [/code:1:956a7f9038] Als ik daarentegen die 200 GB harde schijf plaats in mijn andere pc met een asus a7v266-e moederbord, dan wordt deze wel correct als een 200 GB harde schijf herkent. En bleek GRUB weer goed te werken. Dus ook al is het voor Linux niet nodig dat de harde schijf correct wordt gedetecteerd door de BIOS, lijkt het voor GRUB wel belangrijk. [quote:956a7f9038="Douwe"] Om mijn nostalgische Cyrix (=~ P2) computer met bijbehorend zeer oud abit mobo te upgraden,[/quote:956a7f9038] Ik heb hier ook nog een oude pc met een abit moederbord. Maar dan met een echte Pentium 2 CPU. Het is de BX6 met een BIOS datum van 21 februari 2000. Een 80 GB harde schijf bleek daarin wel door de BIOS herkent te worden als een 80 GB harde schijf. Daarop bleek Linux en GRUB goed te werken.
Link naar reactie
  • 0
[quote:966852eb91="Bamboe"]Als grub het niet doet op zo'n configuratie, zou ik gewoon lilo proberen, uit mijn ondervinding blijkt dat dat minder snel lastig doet dan grub.[/quote:966852eb91] Het was inderdaad de bedoeling, toen die 200 GB harde schijf nog in die pc zat met dat asus cuv4x-d moederbord, ook LILO te proberen. Maar toen ik via YAST, LILO selecteerde, en koos de /boot/grub/menu.lst te converteren naar een /etc/lilo.conf, werd het installeren naar de MBR geweigerd. Ook commando lilo leverde een foutmelding op. Ik heb de geconverteerde /etc/lilo.conf overigens niet gecontroleerd op fouten. Want ik neem aan dat YAST een /boot/grub/menu.lst wel foutloos moet kunnen converteren naar een /etc/lilo.conf. De /boot/grub/menu.lst was in ieder geval goed. Want ik had alle partities van die 80 GB harde schijf, dus ook die partitie van SuSE 9.2, gekopieerd met Partitie-Expert 9.0 naar die 200 GB harde schijf. Bovendien heeft bij mij deze 200 GB harde schijf 3 primaire (NTFS en FAT32) partities, waarvan er maar 1 tegelijk zichtbaar en actief mag zijn. Dat wordt zover ik me kan herinneren niet door alle versies van LILO ondersteund.
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...