Ga naar inhoud
  • 0

Postfix smtp niet bereikbaar vanaf andere pc


anoniem

Vraag

Ik gebruik postfix met Mandrake 10.0. Alles lijkt te werken, ik kan mail verzenden vanaf de opdrachtprompt; fetchmail werkt; imap werkt. Ik kan echter niet vanaf een andere PC mail verzenden via de postfix-pc. Als foutmelding krijg ik dat de verbinding geweigerd wordt. in /etc/shorewall/rules heb ik de laatste regel tijdelijk gezet op: ACCEPT net $FW all - dus volgens mij moet alles doorgelaten worden. De laatste regel van /etc/hosts.allow heb ik gezet op: ALL : ALL : ALLOW Dus ook dat mag het probleem niet zijn. ps aux | grep postfix levert: syslogd -m 0 -a /var/spool/postfix/dev/log /usr/lib/postfix/master qmgr -l -t fifo -u -c tlsmgr -l -t fifo -u -c pickup -l -t fifo -u -c -o content_filter -o receive_override_options grep postfix Wat kan het probleem zijn?
Link naar reactie

6 antwoorden op deze vraag

Aanbevolen berichten

  • 0
Vanaf de pc in kwestie werkt het wel ? Dan zijn er 2 dingen die dit kunnen veroorzaken, namelijk een firewall of een foutieve configuratie van postfix. Zelf denk ik dat dit laatste het geval is. Postfix is voor mij al weer een tijdje geleden, maar ik vermoed dat de relay functie nog uit staat, deze staat standaard uit wat op zich een goede zaak is. Wat je moet doen is dus relay beschikbaar maken voor je interne netwerk. Dus ergens in de postfix congif zul je enkele opties moeten veranderen. Zo even uit het het hoofd (lang geleden) iets van "Mynetworks = 192.168.1.0/24" in de main.cf (als ik me niet vergis) veranderen als je lan de ip-adressen in de 192.168.1.x reeks verdeeld. Verder natuurlijk "mydestination" correct invullen om onnodige spam te voorkomen...., volgens mij is dit al genoeg om vanaf je eigen netwerk te kunnen mailen via deze postfix machine :). Er wel goed op letten dat je niet openrelay bent voor de buitenwereld... suc6
Link naar reactie
  • 0
mynetworks staat volgens webmin op 'default (all attached networks)'. Het ip-adres van de postfix-server is 192.168.0.2, dat van de client is 192.168.0.90. Dus relaying moet goed gaan volgens mij. Ik heb diverse bestanden in /var/log bekeken, maar ik kan geen foutmelding van postfix vinden, alleen bevestigingen dat de lokale sendmail-commando's gelukt zijn. Wanneer ik met putty naar poort 25 'telnet', krijg ik een 'connection refused' en niet een melding dat relaying niet toegestaan is.
Link naar reactie
  • 0
[quote:51291b2351="Peter Willemsen"]mynetworks staat volgens webmin op 'default (all attached networks)'. Het ip-adres van de postfix-server is 192.168.0.2, dat van de client is 192.168.0.90. Dus relaying moet goed gaan volgens mij. Ik heb diverse bestanden in /var/log bekeken, maar ik kan geen foutmelding van postfix vinden, alleen bevestigingen dat de lokale sendmail-commando's gelukt zijn. Wanneer ik met putty naar poort 25 'telnet', krijg ik een 'connection refused' en niet een melding dat relaying niet toegestaan is.[/quote:51291b2351] Dat zou op een gesloten poort kunnen wijzen, maar dan kun je volgens mij lokaal ook niet mailen. Wat Yohanman voorstelde lijkt mij een heel plausibele verklaring, je zit niet in het 'trusted' network, dus zul je aan die default instelling moeten knutselen. Goed lezen, de postfix configfile is vrij goed gedocumenteerd.
Link naar reactie
  • 0
Tja, het was inderdaad mynetworks... :) Alleen in eerste instantie probeerde ik het verkeerd. Deze parameter stond gedocumenteerd als 'net/mask' en bij mask dacht ik aan iets als '255.255.255.0'. Dat is hier dus niet de bedoeling... Zonder verder naar de post van yohanman te kijken, probeerde ik 192.168.0.0/8 omdat ook 127.0.0.0/8 vermeld staat. Dat werkte niet, maar pas later ontdekte ik in de logs dat het aan het netmask lag. OK nu heb ik begrepen dat de mask aangeeft hoeveel bits (van links af gezien, deed ik eerst ook al verkeerd) van belang zijn en 192.168.0.0/24 werkt perfect. Bedankt voor de hulp!
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...