Ga naar inhoud
  • 0

Lettertype bestandsnamen van Linux in Windows met Knoppix


anoniem

Vraag

Hallo, Ik heb mbv Knoppix (K3b) een groot aantal Windows .doc-bestanden op een CD (gelukkig een -RW!) gebrand. Ik heb hiervoor de door K3b aanbevolen "Rock Ridge extensions" gebruikt. De filenamen zien er in Knoppix prima uit, voor zover ik kan nagaan net als het origineel. Maar als ik die CD in Windows wil terugzetten dan krijg je (in de Verkenner tenminste, verder heb ik het nog niet geprobeerd) de bestandsnamen allemaal geheel met hoofdletters en de spaties zijn vervangen door "underscores". Heb ik iets verkeerd gedaan, of is dit een onontkoombaar verschijnsel. Bedankt voor elke tip! Rob
Link naar reactie

8 antwoorden op deze vraag

Aanbevolen berichten

  • 0
Het is af te raden de volgende tekens in linux bestandsnamen te gebruiken: (!@#$%^&*()[]{}`' |/|;<>) Tevens mogen linuxbestandsnamen [b:b1398810ac]geen spaties[/b:b1398810ac] bevatten. Vandaar dat knoppix de spaties vervangen heeft door een underscore. De oorzaak van de hoofdletters weet ik niet. Even off-topic een leuk truukje om linuxbestanden met een bijvoorbeeld een * als bestandsnaam te maken is het volgende: mkdir * --> zal niet lukken maar doe nu maar eens: mkdir "*" O ja het is ook af te raden om bestanden een naam te geven als bijv. -R ;)
Link naar reactie
  • 0
[quote:f820992f45="maximilaan"]was het wel verstandig om de cd met rock ridge te branden als hij bedoeld was voor Windows? Linux kan overigens prima overweg met bestandsnamen met spaties ;) Max[/quote:f820992f45] Linux kan wel met spaties in bestandsnamen overweg maar iedereen die serieus met linux bezig zal het gebruik van spaties afraden. Tevens zal elk goed linuxboek spaties nooit aanraden. Ik\ zie\ dit\ liever\ dit\ niet\ in\ de\ shell.txt Maarja KDE is net windows dus dan zal je het bovenstaande wel niet zien :wink:
Link naar reactie
  • 0
Sorry Max, zoals ik al schreef weet ik bijna niets van Linux. Welke setting had ik dan moeten gebruiken? Nu ik het toch over heb: in Konqueror zie je de "gebrande" namen op volle lengte. Maar als je ze met de Windows Verkenner bekijkt dan zijn ze behalve alleen met hoofdletters en underscores ook nog eens ingekort (de lange namen dan...) tot max. 31 tekens. Dat lijkt me helemaal niet logisch, maar er zal wel een reden voor zijn? En het belangrijkste - is er wat aan te doen? Is er een setting waarbij Windows de bestandsnamen wél goed kan lezen? Alvast bedankt, Rob
Link naar reactie
  • 0
[quote:fdcff7c9d1="m3ssi4h"] Linux kan wel met spaties in bestandsnamen overweg maar iedereen die serieus met linux bezig zal het gebruik van spaties afraden. Tevens zal elk goed linuxboek spaties nooit aanraden.[/quote:fdcff7c9d1] het gebruik van spaties afraden is iets anders als het niet mogen gebruiken van spaties in Linux. Met laatste zeg je impliciet dat dat niet mogelijk is. [quote:fdcff7c9d1] Ik\ zie\ dit\ liever\ dit\ niet\ in\ de\ shell.txt Maarja KDE is net windows dus dan zal je het bovenstaande wel niet zien :wink:[/quote:fdcff7c9d1] Noem een grafisch programma, anders dan kde, dat dat wel laat zien? Verder ging het om een cdrom die onder Windows gebruikt moet worden dus ;) Max
Link naar reactie
  • 0
[quote:70be09045a="r.bornkamp"]zoals ik al schreef weet ik bijna niets van Linux. [/quote:70be09045a] Da's in dit geval niet erg, omdat je een Windows-geschikte cd wilt maken, en dus bekend moet zijn met de beperkingen van dat OS. [quote:70be09045a] Welke setting had ik dan moeten gebruiken? [/quote:70be09045a] Microsoft Joliet. Windows gebruikt in principe Joliet-extensies bij cd-roms. of zoals k3b het zegt: [code:1:70be09045a] <p>Als deze optie is ingeschakeld zal K3b de aanvullende Joliet-extensie toevoegen aan het ISO-9660 bestandssysteem.\n <p>Joliet is geen internationaal geaccepteerde standaard zoals ISO-9660 of Rock Ridge. Joliet wordt voornamelijk op Windows-systemen gebruikt.\n <p>Joliet laat niet alle karakters toe. Daarom zijn Joliet-bestandsnamen niet identiek aan de bestandsnamen op de schijf (zoals wel het geval bij Rock Ridge). Joliet heeft een lengtelimiet voor bestandsnamen van 64 karakters (onafhankelijk van de tekenset en het type, bijvoorbeeld Europees versus Japans). Dit is vervelend omdat moderne bestandssystemen allemaal 255 karakters per padnaamcomponent toelaten.\n <p>Joliet gebruikt de UTF-16-codering.\n <p><b>Opgepast:</b> met uitzondering van Linux en FreeBSD zijn er geen POSIX-achtige besturingssystemen die Joliet ondersteunen. Daarom kun u beter <b>geen cd's met alleen de Joliet-extensie</b> maken. [/code:1:70be09045a] Je kunt meerdere bestandssystemen tegelijk gebruiken, dus vink zowel rockridge als ook joliet aan. Let ook op de spatiebehandeling onderaan het dialoogvenster. [quote:70be09045a] Nu ik het toch over heb: in Konqueror zie je de "gebrande" namen op volle lengte. [/quote:70be09045a] Yeps, maar Linux heeft dan ook geen moeite met het goed uitlezen van rock ridge :) Max
Link naar reactie
  • 0
Nou, eerlijk gezegd ben ik niet echt wijzer geworden (lijkt me). Maar ik zal in elk geval de Joliet/Rock Ridge combinatie proberen. Maar e.e.a. verklaart niet waarom Windows (dat m.i. tegenwoordig 255 lettertekens in de bestandnaam kan hebben) maar een string van 31 tekens leest. Ik zal het resultaat morgen meedelen... Mocht iemand nog wat te binnen schieten, dan hoor ik het graag! Rob
Link naar reactie
  • 0
[quote:95bd64a9d0="r.bornkamp"] Maar e.e.a. verklaart niet waarom Windows (dat m.i. tegenwoordig 255 lettertekens in de bestandnaam kan hebben) maar een string van 31 tekens leest.[/quote:95bd64a9d0] Lees het stukje over joliet eens, de beperking zit niet in Windows, maar in de MS-specificatie van dat formaat. Verder verwijs ik je graag naar Internet, om informatie te vinden over de verschillende cdrom-formaten. Max
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...