Ga naar inhoud
  • 0

Slackware 9.0 kan niet worden geinstalleerd


anoniem

Vraag

Aanbevolen berichten

  • 0
Recente versies van slackware booten op sommige oudere pc's niet van CD. Dat komt omdat de bios van zulke pc's enkel floppy-emulatie ondersteunt voor het booten van een CD (en dat is eigenlijk verouderd). Je kan proberen via sbootmgr, te downloaden op [url]ftp://ftp.kpn.be/pub/slackware/slackware-current/isolinux/sbootmgr[/url]. Dat is een bootfloppy image, en als je die op diskette schrijft en van die diskette start heb je nadien de mogelijkheid om van CD verder te starten. Overigens raad ik aan een nieuwere versie van slackware te installeren, versie 9.1 is al een tijd uit en binnenkort komt wschl 9.2 of 10.0 uit. Je kan ook de current-versie installeren, die eigenlijk 9.2/10.0 in ontwikkeling is (deze is zeer stabiel). Je kan (onofficiele) iso's van slackware-current downloaden op [url]ftp://ftp.slackware.org.uk/unofficial-isos/[/url].
Link naar reactie
  • 0
Het probleem zit hem niet in het feit dat de cd niet opstart. Als ik de computer met de cd opstart krijg ik zoiets te zien: FD System type (oo) daarna gaat de computer verder met het opstarten van windows. de bootable floppy's hebben ook niet geholpen, want de computer blijft slurpen op de a: schijf terwijl er niks gebeurd. Nog enig idee? bedankt,
Link naar reactie
  • 0
Ik heb nogmaals geprobeerd een bootable floppy te maken, en je raad het al, nu lukte het me wel :) De cd wordt nu wel gelezen als de computer wordt opgestart. Slackware 9.0 had ik trouwens gekozen, omdat het maar 700mb groot was om te downloaden. Ik heb niet zo'n snelle internet verbinding :P Alsnog bedankt,
Link naar reactie
  • 0
Ja, als je nog een fat partititie hebt op je harde schijf kan je altijd proberen met loadlin de installer aan de gang te krijgen. Zet bv. in de directory c:\loadlin de volgende bestanden: bzImage, te vinden op [url]http://ftp.scarlet.be/pub/slackware/slackware-9.0/kernels/bare.i/[/url], initrd.img, te vinden op [url]http://ftp.scarlet.be/pub/slackware/slackware-9.0/isolinux/[/url], en de inhoud van loadlin16c.zip, te vinden op [url]http://ftp.scarlet.be/pub/slackware/slackware-9.0/kernels/[/url] (je hebt eigenlijk enkel loadlin.exe nodig) Je zou dan vanuit dos of windows 98 dos-mode (evt. via win98 bootdiskette) de installer moeten kunnen starten door het commando [code:1:d530ae0fab]loadlin bzImage initrd=initrd.img root=/dev/ram rw[/code:1:d530ae0fab] uit te voeren vanuit de directory c:\loadlin Succes!
Link naar reactie
  • 0
[quote:bea65163b1="tomschout"]Ik heb nogmaals geprobeerd een bootable floppy te maken, en je raad het al, nu lukte het me wel :) De cd wordt nu wel gelezen als de computer wordt opgestart. Slackware 9.0 had ik trouwens gekozen, omdat het maar 700mb groot was om te downloaden. Ik heb niet zo'n snelle internet verbinding :P Alsnog bedankt,[/quote:bea65163b1] als je ooit nog een snelle verbinding krijg dan zou je de boel nog kunnen updaten met [url=http://www.swaret.org]swaret[/url]
Link naar reactie
  • 0
Nog even een vraag, Ik heb nu een linux partitie aangemaakt en de te installeren programma's gekozen. Je moet dan klikken op 'installeren' en de onderdelen worden geinstalleerd. De computer wordt opnieuw opgestart, maar dit gaat natuurlijk via de bootable gemaakte diskette. Nu wordt alles weer opnieuw aan me gevraagd. Dus de primaire partitie instellen, te installeren programma's instellen etc. Als ik de bootable diskette (speciaal gemaakt om cd rom te lezen) eruit haal, en de computer opnieuw opstart kom je uiteindelijk in het scherm 'druk op een toets om opnieuw op te starten'. Hoe kan slackware op de juiste manier via de bootable diskette geinstalleerd worden (is dit dat loadlin wat je opnoemde)
Link naar reactie
  • 0
Nee, bij mij staat er na een paar seconden 'configuration/installation complete' meer niet. Ik heb het volgende gedaan: doel geselecteerd - installatie via cdrom aangeven - packages geselecteerd - installation full - (melding configuration installation complete na een seconde of 5) - reboot ik krijg dan dit te zien 'press a key to reboot'
Link naar reactie
  • 0
[quote:c22b9fa8ef="tomschout"]ik krijg dan dit te zien 'press a key to reboot'[/quote:c22b9fa8ef] Het lijkt er op dat je geen bootloader geïnstalleerd hebt in de MBR. Heb je wellicht stap [url=http://darkstar.ist.utl.pt/slackware/slackware-current/Slackware-HOWTO]4.6 The CONFIGURE option 4.7 LILO[/url] overgeslagen? Wat je nu kunt gaan doen, is de PC opstarten met de Slackware bootdisk, en bij typen bij de boot: [code:1:c22b9fa8ef] linux root=/dev/hdxx [/code:1:c22b9fa8ef][Enter] In plaats van die xx typ je de root partitie van je Slackware installatie. Bijvoorbeeld: /dev/hda5 Dan log je in als root, en draait [code:1:c22b9fa8ef] liloconfig [/code:1:c22b9fa8ef] [Enter] dan installeer je de lilo in de MBR. Als je kiest voor diskette vergeet dan niet de installatie diskette te verwijderen, en een lege diskette te plaatsen. Had je trouwens al addswap gedaan? [quote:c22b9fa8ef="tomschout"]heb ik het verkeerde bestandssysteem gekozen in het begin?[/quote:c22b9fa8ef] Welke bestanden systeem had je dan gekozen? De bestandensystemen waaruit je kunt kiezen tijdens de Slackware installatie, zit geen verkeerde bestandensysteem bij. [quote:c22b9fa8ef="tomschout"] ik lees nu veel over een rootdisk, heb ik deze nodig?[/quote:c22b9fa8ef] Je start de PC op met de bootdiskette. Als de rootdisk nodig is, wordt er wel om gevraagd.
Link naar reactie
  • 0
Slackware boot standaard in Runlevel 3 (init3 , alleen tekstmode) als je eerst even je X configured dmv xf86cfg, en dan even /etc/inittab edit.. en default runlevel op 4 zet, dan start ie automatisch in GUI. Als je KDE draait, dan ik het ook wel handig om KDM te laten starten ipv GDM, dan moet je /etc/rc.d/rc.4 even aanpassen
Link naar reactie
  • 0
Slackware start standaard in een [u:c99b753b7b]niet[/u:c99b753b7b]-grafische omgeving (tekstmodus) je kan je GUI starten door startx in te voeren (maar dan moet je hem wel eerst configureren met xf86cfg ) Als je wilt dat je systeem altijd in GUI start, dan moet je /etc/inittab aanpassen met een editor. er staat dan na een paar regels een regel met "Default runlevel , do not set...... " die moet je dan aanpassen, normaal staat er : id:3:initdefault: , dan moet je even die 3 voor een 4 veranderen, en dan boot je systeem standaard in GUI ([b:c99b753b7b] Configureer wel eerst je grafische omgeving met xf86cfg want anders word het moeilijk![/b:c99b753b7b]) dan start je systeem dus standaard in GUI, Als je KDE gaat draaien, dan is het ook wel zo makkelijk om KDM als inlog manager te nemen, (inlogmanager in GUI dus) als je dat wilt, dan moet je /etc/rc.d/rc.4 aanpassen, en van: # Try to use GNOME's gdm session manager: if [ -x /usr/bin/gdm ]; then exec /usr/bin/gdm -nodaemon fi dit maken: # Try to use GNOME's gdm session manager: #if [ -x /usr/bin/gdm ]; then # exec /usr/bin/gdm -nodaemon #fi dan start KDM als grafische inlogmanager.
Link naar reactie
  • 0
Dat is al een hele aardige omschrijving maar ik vrees nog niet simpel genoeg. Oke, log eerst eens in als root. Je tikt gewoon root in achter 'login:' en geeft het password dat je tijdens de installatie hebt opgegeven. Je bent nu ingelogd als de grote baas. Onder GNU/Linux is het echter goed gebruik dat je als een normale user werkt zonder rechten, deze user gaan we eerst aanmaken: [code:1:ce27811c4b] adduser [/code:1:ce27811c4b] Beantwoord nu de vragen. Geef een naam op, bijvoorbeeld 'tom', de rest kun je gewoon accepteren door op enter te drukken totdat je bij additionele groups komt. Vul hier 'disk,floppy,games' in. Nu heb je een normale user aangemaakt, maar we moeten de grafische omgeving nog configgen tik: [code:1:ce27811c4b] xf86config [/code:1:ce27811c4b] En beantwoord simpelweg de vragen. Nu kun je testen of het werkt door 'init 4' te tikken. Je zou nu een grafische login manager moeten zien en je kan dan als de user 'tom' inloggen. Als dit inderdaad werkt kun je in het bestand '/etc/inittab' instellen dat de grafische omgeving standaard moet worden gestart: [code:1:ce27811c4b] vim /etc/inittab [/code:1:ce27811c4b] Je komt nu in de bekende editor vim. Je moet in de door Chestah genoemde regel een 3 in een 4 veranderen zo dus: [code:1:ce27811c4b] # Default runlevel. (Do not set to 0 or 6) id:3:initdefault: [/code:1:ce27811c4b] wordt [code:1:ce27811c4b] # Default runlevel. (Do not set to 0 or 6) id:4:initdefault: [/code:1:ce27811c4b] Dit doe je door de 3 met 'delete' weg te halen, op 'i' te drukken om naar de insert modus te gaan, een '4' te tikken, op escape te drukken en vervolgens ':' te doen. Nu kun je onderin commando's opgeven, doe 'wq' wat neerkomt op opslaan (write) en de editor afsluiten (quit). Nu start je PC voortaan direct in grafische modus. Het is heel handig om goed met vim overweg te kunnen, lees daarom: http://www.bilbos-stekkie.com/vim/index.html Op http://wiki.nedlinux.nl/index.php?page=Slackware vind je heel veel bruikbare informatie over Slackware. Succes en als er vragen zijn roept je maar ;)
Link naar reactie

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...