Ga naar inhoud
  • 0

Installeren van Samba 3.0.2a


anoniem

Vraag

Ik wil een samba-3.0.2a installeren, Het 'tar' command voor uitpakken gaat goed. Hier gaat het fout: linux:/home/hws/samba-3.0.2a # ./configure bash: ./configure: Onbekend bestand of map Wat doe ik fout? Ik heb begrepen dat daarna nog de commando's 'make' en 'make install' moeten worden uitgevoerd. Graag hulp. -hws-
Link naar reactie

8 antwoorden op deze vraag

Aanbevolen berichten

  • 0
lckarssen schreef: Als je in de directory kijkt, staat het bestand configure er dan wel bij? (gebruik ls -l om ook te controleren of configure wel executable is). Dit bestand mist idd; ik haalde het bestand "samba-3.0.2a.tar.gz" van "de.samba.org/samba.org/". Dit lijkt mij onverdacht. Heb ik wel het juiste bestand?
Link naar reactie
  • 0
lckarssen schreef: Als je in de directory kijkt, staat het bestand configure er dan wel bij? (gebruik ls -l om ook te controleren of configure wel executable is). Dit bestand mist idd; ik haalde het bestand "samba-3.0.2a.tar.gz" van "de.samba.org/samba.org/". Dit lijkt mij onverdacht. Heb ik wel het juiste bestand?
Link naar reactie
  • 0
Zit er niet een directory src of source in de samba-dir? Volgens mij moet je eerst daarheen gaan, dan zal daar configure wel instaan. Om even in te haken op wat Bilbo zei: [quote:1e1e3c0615]Het ziet er naar uit dat je echt weet wat je doet, in zo'n geval zou ik een package zoeken geschikt voor jouw distro.[/quote:1e1e3c0615] Samba is niet het meest ideale programma om te leren hoe je source moet compileren en installeren. Anderzijds, het getuigt van een goede instelling om dingen zelf te willen compileren. Uiteindelijk geeft je dat de meeste keuzevrijheid. Succes!
Link naar reactie
  • 0
Inmiddels had ik wat andere bestanden opgehaald. Na wat uitproberen lijkt het alsof Samba3 is geinstalleerd; zeker ben ik nog niet. Hieronder volgen de opdrachten en meldingen zoals die in de console verschenen: linux:/home/hws # # Lopende Samba gestopt linux:/home/hws # rcsmb stop && rcnmb stop Shutting down Samba classic SMB daemon                                                                             done Shutting down Samba classic NMB daemon                                                                             done # Update geprobeerd linux:/home/hws # rpm -U samba3-3.0.2a-30.i586.rpm error: Failed dependencies:         samba3-client is needed by samba3-3.0.2a-30         samba3-winbind is needed by samba3-3.0.2a-30 # Na lezing SuSE administrator Guide linux:/home/hws # rpm -F samba3-winbind-3.0.2a-30.i586.rpm linux:/home/hws # rpm -F samba3-client-3.0.2a-30.i586.rpm linux:/home/hws # rpm -F samba3-3.0.2a-30.i586.rpm # Hoera, geen foutmeldingen # Maar weer even starten linux:/home/hws # rcnmb start && rcsmb start Starting Samba classic NMB daemon                                                                                 done Samba SMB: Waiting for cupsd to get ready (29s)                                                                   done Starting Samba classic SMB daemon                                                                                 done linux:/home/hws # # Lijkt mooi, maar is dit nu de oude of de nieuwe? Hoe kun je de versie van een programma achterhalen? -hws-
Link naar reactie
  • 0
Je zal je wel weer beledigd voelen, maar Samba is niet het soort pakket waarbij je weg komt met het niet lezen van de documentatie. Je installatie heeft een heleboel documentatie.... ik raad je aan die te lezen Nog maar een freeby dan: Versie achterhaal je met het commando smbd -V details: man smbd. man nmbd, man smb.conf, man swat, je lokale /usr/doc en google
Link naar reactie

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...