Ga naar inhoud
  • 0

3D op knoppix met nvidiakaart?


anoniem

Vraag

Hallo, Misschien kan iemand mij helpen. Ik heb knoppix 3.2 op mijn harde schijf. Alles werkt prima, maar geen 3d :cry: voor mijn nvidia ti4200 kaart om eens een stevig potje tuxkart te spelen. In het verleden met debian heb ik met de website van s.bouncybouncy.net op een eenvoudige wijze de 3d aan de praat gekregen. Nu lees alleen maar ingewikkelde werkwijzes hoe je dat wel kunt doen... Heeft er iemand een goede tip voor deze beginner??
Link naar reactie

11 antwoorden op deze vraag

Aanbevolen berichten

  • 0
[quote:ea4ffc8047="Egghard"] Ik heb knoppix 3.2 op mijn harde schijf. Alles werkt prima, maar geen 3d :cry: voor mijn nvidia ti4200 kaart om eens een stevig potje tuxkart te spelen. [/quote:ea4ffc8047] Ik heb dit al eens geprobeerd, maar dan met knoppix 3.1 Het lukte me toen niet. http://forum.computertotaal.nl/phpBB2/viewtopic.php?p=574736&highlight=#574736 Maar als je het toch wilt proberen. De benodigde drivers staan op ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4363 NVIDIA_kernel-1.0-4363.tar.gz en NVIDIA_GLX-1.0-4363.tar.gz
Link naar reactie
  • 0
Ik heb inmiddels de Knoppix 3.2 toch maar even op HD geinstalleerd. Het is me nog niet gelukt een eenvoudige manier te vinden om de Nvidia drivers te installeren. Maar zo ongeveer zou je het kunnen proberen. Als je Internet verbinding in Knoppix werkt, open je een Shell en log in als superuser [code:1:68ecc8fabd] su Password: [/code:1:68ecc8fabd] typ [code:1:68ecc8fabd] apt-get update [/code:1:68ecc8fabd] Dan kernel-source downloaden. [code:1:68ecc8fabd] apt-get install kernel-source-2.4.21 [/code:1:68ecc8fabd] Uitpakken kernel-source [code:1:68ecc8fabd] cd /usr/src tar -xjvf kernel-source-2.4.21.tar.bz2 [/code:1:68ecc8fabd] config file naar source kopieren [code:1:68ecc8fabd] cp /boot/config-2.4.20-xfs /usr/src/kernel-source-2.4.21/.config [/code:1:68ecc8fabd] Aanpassen kernel opties [code:1:68ecc8fabd] cd /usr/src/kernel-source-2.4.21 make menuconfig [/code:1:68ecc8fabd] Selecteer File systems [Enter] Zorg er voor dat er voor het file system dat je gebruikt een sterretje staat. Bij mij is dat ext3 Dan Exit Dialoog: Do you wish to save your new kernel configuration. Yes is voor geselecteerd, dan [Enter] [code:1:68ecc8fabd] make dep make modules make modules_install make bzImage [/code:1:68ecc8fabd] Dan [code:1:68ecc8fabd] cp System.map /boot/System.map-2.4.21 cd arch cd i386 cd boot cp bzImage /boot/vmlinuz-2.4.21 [/code:1:68ecc8fabd] /etc/lilo.conf of /boot/grub/menu.lst aanpassen. Ik had problemen met initrd. Die heb ik bij mij weggelaten. [url=http://download.nvidia.com/XFree86/Linux-x86/1.0-4363/NVIDIA-Linux-x86-1.0-4363.run]Nvidia run file[/url] downloaden. Als superuser [code:1:68ecc8fabd] sh NVIDIA-Linux-x86-1.0-4363.run [/code:1:68ecc8fabd] Toevoegen nvidia module aan /etc/modules [code:1:68ecc8fabd] cd /etc vi modules [/code:1:68ecc8fabd] Voeg daar toe [b:68ecc8fabd] nvidia [/b:68ecc8fabd] [b:68ecc8fabd] Esc : wq [/b:68ecc8fabd] [Enter] Bij mij is het installeren van de Nvidia drivers in de Knoppix 3.2 hd-install gelukt. Ik heb deze instukties echter achteraf geschreven. Er zouden dus nog (typ)fouten in kunnen staan. :roll: [b:68ecc8fabd] Update: [/b:68ecc8fabd] Ook is het nodig een paar wijzigingen aan te brengen in /etc/X11/XF86Config-4 in Section "modules" Daar behoort in te staan [b:68ecc8fabd] Load "glx" [/b:68ecc8fabd] Als er echter in staan [b:68ecc8fabd] dri [/b:68ecc8fabd] en [b:68ecc8fabd] Glcore [/b:68ecc8fabd] kan daar waarschijnlijk beter een hekje voor worden geplaatst. [code:1:68ecc8fabd] Load "glx" # Load dri # Load Glcore [/code:1:68ecc8fabd] De andere modules in Section "modules" kunnen ongewijzigd blijven. In Section "Device" staat waarschijnlijk zoiets als [b:68ecc8fabd] Driver "nv" [/b:68ecc8fabd] Deze behoort dan te worden gewijzigd in [b:68ecc8fabd] Driver "nvidia" [/b:68ecc8fabd]
Link naar reactie
  • 0
Bedankt Jolo, Ik dacht dat mijn treurig berichtje de afsluiter zou zijn. Na mijn vakantie zag ik dat je dit helemaal hebt uitgewerkt. Inmiddels heb ik Knoppix vervangen met Debian testing. Ik wist uit het verleden dat met http://s.bouncybouncy.net het juist configureren van de nvidiakaart een eitje was. Helaas is bouncybouncy uit de lucht. Inmiddels heb ik op debian jouw aanwijzingen opgevolgd, maar helaas nog niet met het gewenste resultaat. Vanavond probeer ik het weer. Geweldig ik leer weer veel. Zelf kernel compileren STOER! :wink:
Link naar reactie
  • 0
Ik kom dus een heel eind. Maar bij het aanpassen van lilo.config gaat het denk ik mis. Ik pas mijn lilo aan in kde (boot manager (lilo) Daarin staat dan als ik probe druk wel LInux Compiled: image=/usr/src/linux/arch/i386/boot/bzImage label="Linux_Compiled" root=/dev/hdb5 read-only optional Wat opvalt is dat de andere kernels wel een bijvoorbeeld: initrd="/boot/initrd.img-2.6.0-test1-1-386" hebben maar linux-compilled heeft dat niet. In /boot staat er ook geen "initrd.img-2.4.20" tussen die ik zou kunnen aanwijzen. Hier doe ik dus nog wat fout. Ik denk dat daarom na het opstarten van sh NVIDIA-Linux-x86-1.0-4363.run ook de melding krijg dat er geen kernel gevonden wordt. (of is dat onzin :roll: ) In ieder geval dat laatste stapje moet ik nog maken maar wat doe ik fout? :o
Link naar reactie
  • 0
[quote:b1a162e14e="Egghard"]Ik kom dus een heel eind. Maar bij het aanpassen van lilo.config gaat het denk ik mis. [/quote:b1a162e14e] Het was eigenlijk de bedoeling de bzImage te kopieren naar de boot map [code:1:b1a162e14e] cp /usr/src/kernel-source-2.4.21/arch/i386/boot/bzImage /boot/vmlinuz-2.4.21 [/code:1:b1a162e14e] en de System.map wordt ook naar de boot map gekopieerd. [code:1:b1a162e14e] cp /usr/src/kernel-source-2.4.21/System.map /boot/System.map-2.4.21[/code:1:b1a162e14e] [code:1:b1a162e14e] image=/boot/vmlinuz-2.4.21 label="Linux_Compiled" root=/dev/hdb5 read-only optional [/code:1:b1a162e14e] En dan [code:1:b1a162e14e] lilo -v [/code:1:b1a162e14e] [quote:b1a162e14e="Egghard"]In /boot staat er ook geen "initrd.img-2.4.20" tussen die ik zou kunnen aanwijzen. Hier doe ik dus nog wat fout.[/quote:b1a162e14e] Als je het Selecteer File system, bijvoorbeeld ext3 in de kernel zet als build-in (een sterrtje dus) dan is die initrd.img niet nodig. Deze kan worden gemaakt met [b:b1a162e14e] mkinitrd [/b:b1a162e14e] zie ook [url=http://groups.google.nl/groups?q=mkinitrd&hl=nl&lr=&ie=UTF-8&oe=UTF-8&selm=3BA6D566.5813A27A%40yahoo.com&rnum=1]deze discussie.[/url]
Link naar reactie
  • 0
Iemand heeft eerder in deze thread een hele mooie beschrijving van een kernel-compilatie gegeven. Het kan in Debian echter makkelijker. Er bestaat een aantal tools in Debian om een zelf een kernel-image deb te maken met behulp van een kernel-source. Voor een groot deel komt het overeen met de beschrijving in deze thread, maar voor informatie zie de Debian Reference Manual, [url=http://www.debian.org/doc/manuals/reference/ch-kernel.en.html]Hoofdstuk 7[/url].
Link naar reactie
  • 0
Het gaat langzaam maar beter, na de aanpassingen heb ik opnieuw geboot. In LILO start ik Linux-compiled. Het lijkt dan even goed te gaan maar dan krijg ik het volgende bericht: [color=orange:1e5fb968c1]VFS: Cannot open root device "345" or 03:45 Please append a correct "root=" boot option kernel panic: VFS: unable to mount root fs on 03:45[/color:1e5fb968c1] Zo dat is ook weer getypt. Maar wat moet ik? :oops: En dat allemaal voor een stevig potje tuxracer! :wink:
Link naar reactie
  • 0
Dit soort foutmeldingen krijg je als de kernel / niet kan mounten. Dit kan verschillende oorzaken hebben: - In lilo verwijs je naar de verkeerde partitie - de partitie is beschadigd - de kernel ondersteunt het type filesystem niet dat je als / wilt mounten. Ik gok dat het laatste het geval is, aangezien je zelf bezig bent geweest met kernels compileren. Heb je al eens geprobeerd om een kernel te compileren via de instructies in de Debian Reference Manual (voor link zie eerder bericht van mij in deze thread) Het is belangrijk om vooraf te beslissen of je initrd wil gebruiken. Zonder initrd, moet je meer drivers mee-compileren in de kernel. Met initrd heb je de mogelijkheid om modules te gebruiken voor bijvoorbeeld ide en ext2/3. Ik kan mij voorstellen dat je initrd niet gebruikt terwijl de kernel daar wel op gecompileerd is.
Link naar reactie
  • 0
[quote:8fcc2120d2="Egghard"]VFS: Cannot open root device "345" or 03:45 Please append a correct "root=" boot option kernel panic: VFS: unable to mount root fs on 03:45 [/quote:8fcc2120d2] Maar wat voor een file system gebruik je? Heb je die file system nog built-in de kernel? Ik gebruik zelf ext3. In de kernel message is daarover het volgende te zien. (ext3 als module via initrd) [code:1:8fcc2120d2] VFS: Mounted root (ext2 filesystem). Journalled Block Device driver loaded kjournald starting. Commit interval 5 seconds EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,5), internal journal EXT3-fs: mounted filesystem with ordered data mode.[/code:1:8fcc2120d2] Of dit (ext3 built-in kernel) [code:1:8fcc2120d2] kjournald starting. Commit interval 5 seconds EXT3-fs: mounted filesystem with ordered data mode. VFS: Mounted root (ext3 filesystem) readonly. Freeing unused kernel memory: 120k freed Adding Swap: 530104k swap-space (priority -1) EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,6), internal journal Real Time Clock Driver v1.10e [/code:1:8fcc2120d2]
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...