Ga naar inhoud
  • 0

KDE 3.1.2 is uit!!!!


anoniem

Vraag

Hallo allemaal, [url=http://www.kde.org/announcements/changelogs/changelog3_1_1to3_1_2.php]KDE 3.1.2 is uitgebracht!!![/url] Hij is te downloaden voor [url=ftp://ftp.kde.org/pub/kde/stable/3.1.2]Redhat, SuSE, Debian, FreeBSD en Turbo Linux[/url]. Andere Linux-smaken volgen... Voor RedHat-liefhebbers: deze [url=http://kde-redhat.sourceforge.net/]site[/url] biedt kde-rpm's aan die alle functionaliteit van KDE bevatten (die RH er uit heeft gesloopt..) Max
Link naar reactie

Aanbevolen berichten

  • 0
Hoi, Ik heb net de upgrade uitgevoerd. Ik moet zeggen: van 3.05 naar 3.1.2 is het wel een hele overgang. Het ziet er in ieder geval gelikt uit. Al mis ik wel nu de optie om mijn KDE-instellingen te bewaren (kon je vroeger even aanvinken). Nu 'restored' KDE mijn hele sessie, terwijl ik eigenlijk altijd gewend ben om vanuit een standaard 'start-configuratie' te werken. Het zal vast wel kunnen, maar dat zoek ik nog wel een keertje uit. Kortom: TOP! Groetjes, Philip
Link naar reactie
  • 0
[quote:8a93a5cd54="maximilaan"]Ik heb voor de aardigheid een ander thema in gebruik, en kde is een stukkie vlotter :) Verder is mozilla 1.4 een aanrader, deze kent geen opstarttijd meer :o Max[/quote:8a93a5cd54] Pardon ?? waardoor kan dat dan of doet mozilla wat OO ook doet nml een prestart invoeren tijdens booten ??
Link naar reactie
  • 0
Ik heb de RPMs (noarch.rpm) gedownload en allemaal in een map gezet. Vervolgens vanaf de prompt heb ik ingetikt: [code:1:510714c60c] cd /home/michael/kde (waar ze dus alolemaal in staan) rpm -Uvh kde* [/code:1:510714c60c] Dan krijg ik van alles op het scherm, een voor een gaat ie de rpms installeren... Maar, als ik daarna herstart en ga kijken bij de versie van mijn kde zie ik nog steeds 3.1.1 staan. Wat doe ik hier fout?
Link naar reactie
  • 0
Hoi, KDE laat zich niet zo makkelijk met de hand installeren vanwege dependencies. Je moet eerst (ik dacht) kdebase3 installeren, daarna de kdelibs3, enzovoorts. En dat heb ik het nog geeneens over het updaten van overige libraries en qt. Heb je niet een configuratietool die de installatie / update voor je kan uitvoeren? De precieze volgorde van installeren kan je vinden op http://www.kde.org Als je met alle geweld handmatig wilt installeren. Zorg ervoor dat je niet in KDE bent (want dan kan je niets de-installeren) en verwijder eerst de oude KDE volledig! Eventueel de oude qt3 ook verwijderen, daarna de nieuwe qt3 installeren, de libs* bestanden installeren en daarna kan je alle overige rpms installeren. In verband met dependencies zou ik wel de opties: '--force --nodeps' meegeven aan rpm. Kortom: weet waar je aan begint :-) O ja, als je alles van KDE installeert neem je ook vaak opties mee die je verder niet gebruikt (maar het is wel de makkelijkste weg). Groet, Philip
Link naar reactie
  • 0
[quote:ba549b1346="my009054"]Ik heb de RPMs (noarch.rpm) gedownload en allemaal in een map gezet. Vervolgens vanaf de prompt heb ik ingetikt: [code:1:ba549b1346] cd /home/michael/kde (waar ze dus alolemaal in staan) rpm -Uvh kde* [/code:1:ba549b1346] Dan krijg ik van alles op het scherm, een voor een gaat ie de rpms installeren... Maar, als ik daarna herstart en ga kijken bij de versie van mijn kde zie ik nog steeds 3.1.1 staan. Wat doe ik hier fout?[/quote:ba549b1346] ehh, noarch is slechts de lokalisatie van kde, heb je alleen noarcrh genomen of ook alles in i386? Verder is de optie kde* niet handig, omdat een aantal pakketten met bijv. een [b:ba549b1346]a[/b:ba549b1346] of [b:ba549b1346]q[/b:ba549b1346] beginnen. Kan best zijn dat doordat die pakketten niet geinstalleerd worden, bijv. kdelibs en/of kdebase niet zijn geinstalleerd. en dan zit je nog in kde 3.1.1. (kun je overigens het best bekijken via [b:ba549b1346]help->info over kde[/b:ba549b1346] Max
Link naar reactie
  • 0
Heb zelf net via rpm [b:99bd74f9aa]-Uvh *.rpm kde[/b:99bd74f9aa] geinstalleerd. Daarbij waren er 2 onopgeloste afhankelijkheden, eentje van een pakket dat TeX nodig had, en kpilot die een bepaalde bibliotheek mistte. Beide pakketten heb ik verwijderd, en toen op nieuw het rpm-commando ingevoerd. Daarna [b:99bd74f9aa]SusEConfig[/b:99bd74f9aa] uitgevoerd, en via [b:99bd74f9aa]init 5[/b:99bd74f9aa] terug naar X en de nieuwe KDE. Bij de eerste start was KDE iets trager, mogelijk omdat het KDE-register (ksycoca) opnieuw gebouwd moet worden. Daarna isie weer als een speer. :) Bij rpm -Uvh *.rpm lost rpm zelf de onderlinge afhankelijkheden op, je hoeft je dus niet druk te maken over de volgorde en zo... Max
Link naar reactie
  • 0
[quote:65cd7242b2] Bij rpm -Uvh *.rpm lost rpm zelf de onderlinge afhankelijkheden op, je hoeft je dus niet druk te maken over de volgorde en zo... [/quote:65cd7242b2] Hoi Max, Bovenstaande is alleen waar (volgens mij) als de geselecteerde bestanden (*.rpm) alle dependencies inderdaad kunnen oplossen. Maar je hebt wel gelijk! Wat betreft al die grafische schillen. Mijn mening over YaST is dat het te gebruikersvriendelijk is geworden: leuk voor mensen die wat minder verstand hebben van linux, maar voor een vergevorderde kenner een ramp! red-carpet bevalt mij gewoon stukken beter. Misschien moest ik ximian maar een keertje proberen :-) Ik wil nog wel even opmerken dat al die grafische tools je veel werk uit handen kunnen nemen, omdat ze zelf 'weten' welke stappen ondernomen moeten worden tijdens een installatieprocedure. Als je zelf 'rpm' gebruikt, heb je toch veel meer rpm-opdrachten nodig om de installatie tot een goed einde te brengen. Tot slot wat betreft mijn opmerking om de oude versie van KDE eerst te verwijderen. De reden waarom ik dat doe is dat ik te vaak heb gehad te denken een upgrade te hebben uitgevoerd, terwijl dit helemaal niet het geval was. Door de oude versie eenvoudigweg te verwijderen, kan dat niet meer voorkomen. Een tikkeltje omslachtig misschien, maar voor mij werkt dat het beste. Groet, Philip
Link naar reactie
  • 0
Bij een major/minor upgrade is dat idd verstandig. (major is bijv. van kde 2 naar kde 3, minor is van kde 3.0x naar kde 3.1.x) Bij een lesser upgrade hoeft dat op zich niet, omdat deze volledig compatible is met de vorige versie. Het onverhoopt door elkaar gebruiken van verschillende modules etc. is dan dus geen enkel probleem. (lesser is een upgrade van bijv. kde 3.1.1. naar kde 3.1.2) Max
Link naar reactie
  • 0
Ik heb hier geprobeerd vanuit init 3 in SuSE 8.2 Prof KDE 3.1.1 te upgraden naar KDE 3.1.2 met de volgende rpm's [code:1:575a86bbee] linux:/home/jolo/suse/kde # ls . kdelibs3-cups-3.1.2-6.i586.rpm libxml2-devel-2.5.7-2.i586.rpm .. kdelibs3-devel-3.1.2-6.i586.rpm libxslt-1.0.23-39.i586.rpm arts-1.1.2-7.i586.rpm kdelibs3-devel-doc-3.1.2-6.i586.rpm libxslt-devel-1.0.23-39.i586.rpm arts-devel-1.1.2-7.i586.rpm kdemultimedia3-devel-3.1.2-6.i586.rpm qt3-3.1.2-40.i586.rpm kde3-i18n-nl-3.1.2-0.noarch.rpm kdenetwork3-3.1.2-7.i586.rpm qt3-devel-3.1.2-40.i586.rpm kdeadmin3-3.1.2-8.i586.rpm kdenetwork3-lisa-3.1.2-7.i586.rpm qt3-devel-doc-3.1.2-40.i586.rpm kdeartwork3-3.1.2-21.i586.rpm kdepim3-3.1.1-110.i586.rpm qt3-devel-tools-3.1.2-47.i586.rpm kdebase3-3.1.2-13.i586.rpm kdepim3-kpilot-3.1.1-110.i586.rpm qt3-extensions-3.1.2-47.i586.rpm kdebase3-devel-3.1.2-13.i586.rpm kdesdk3-3.1.2-16.i586.rpm qt3-man-3.1.2-47.i586.rpm kdebase3-ksysguardd-3.1.2-13.i586.rpm kdesdk3-devel-3.1.2-16.i586.rpm qt3-mysql-3.1.2-47.i586.rpm kdebase3-nsplugin-3.1.2-13.i586.rpm kdetoys3-3.1.2-9.i586.rpm qt3-non-mt-3.1.2-39.i586.rpm kdeedu3-3.1.2-9.i586.rpm kdeutils3-3.1.2-9.i586.rpm qt3-postgresql-3.1.2-47.i586.rpm kdegames3-3.1.2-7.i586.rpm kdeutils3-devel-3.1.2-9.i586.rpm qt3-unixODBC-3.1.2-47.i586.rpm kdegraphics3-3.1.2-12.i586.rpm libart_lgpl-2.3.10-100.i586.rpm quanta-3.1.2-8.i586.rpm kdegraphics3-devel-3.1.2-12.i586.rpm libart_lgpl-devel-2.3.10-100.i586.rpm kdelibs3-3.1.2-6.i586.rpm libxml2-2.5.7-2.i586.rpm [/code:1:575a86bbee] Eerst verscheen er na rpm -Uvh *.rpm [code:1:575a86bbee] alsa-devel is needed by arts-devel-1.1.2-7 libvorbis-devel is needed by kdelibs3-devel-3.1.2-6 fam-devel is needed by kdelibs3-devel-3.1.2-6 [/code:1:575a86bbee] Na deze via Yast2 te hebben geinstalleerd en rpm -Uvh *.rpm verscheen [code:1:575a86bbee] linux:/home/jolo/suse/kde # rpm -Uvh *.rpm package libart_lgpl-2.3.11-24 (which is newer than libart_lgpl-2.3.10-100) is already installed package libxslt-1.0.26-12 (which is newer than libxslt-1.0.23-39) is already installed linux:/home/jolo/suse/kde # [/code:1:575a86bbee] Ik gebruik [b:575a86bbee] rpm -Uvh --force --nodeps *.rpm [/b:575a86bbee] liever niet, als het niet echt nodig is. Heeft iemand suggesties? :roll:
Link naar reactie
  • 0
ik heb gewoon ff [b:2bd038c937]nice -n 19 emerge arts kdelibs kdebase kdepim kdenetwork kdegraphics kdemultimedia kdeartwork >& emerge-kde-3.1.2.log &[/b:2bd038c937] ingetypt (Gentoo is wel makkelijk hoor!!). Dat is wat ik altijd van KDE gebruik. Hij is nu al de hele dag aan het compilen, maar ondertussen werk ik er lekker mee door (maar ook andere dingen gedaan natuurlijk :-) )
Link naar reactie
  • 0
Tja, alle dependencies zijn dus opgelost, en 2 pakketten die je wilt installeren zijn ouder dan die nu op de schijf staan. libart en libxlt zijn geen kde-programma's, maar bibliotheken die suse bij de kde-installatie levert voor eventuele onopgeloste afhankelijkheden. Als ze (in een nieuwere vorm) reeds op je systeem staan hoef je de meegeleverde versies volgens mij niet te installeren. Max
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...