Ga naar inhoud
  • 0

[Slackware Current] kdebase-3.1 not found kdelibs


anoniem

Vraag

In Slackware Current 20030123 met gecompileerde kernel 2.4.20 heb ik geinstalleerd [url=ftp://ftp.kpn.be/pub/linux/slackware/slackware-current/extra/kde-3.1rc5/qt-3.1.1-i386-1.tgz]qt-3.1.1[/url] en Cups-1.1.18 Ik heb de [url=http://kde.org/info/3.1.html]kde 3.1 sources[/url] gedownload. Ik heb zonder foutmeldingen arts-1.1 en kdelibs-3.1 kunnen compileren met [code:1:5a90fe9f1b] ./configure make make install [/code:1:5a90fe9f1b] Maar bij kdebase-3.1 (output ingekort) ./configure [code:1:5a90fe9f1b] checking for snprintf... yes checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include checking for IceConnectionNumber in -lICE... yes checking for libXext... yes checking for Xinerama... no checking for pthread_create in -lpthread... yes checking for extra includes... no checking for extra libs... no checking for libz... -lz checking for libpng... -lpng -lz -lm checking for libjpeg6b... no checking for libjpeg... -ljpeg checking for Qt... libraries /usr/lib/qt/lib, headers /usr/local/qt/include using -mt checking if Qt compiles without flags... no checking for moc... /usr/local/qt/bin/moc checking for uic... /usr/local/qt/bin/uic checking whether uic supports -L ... yes checking whether uic supports -nounload ... yes checking if Qt needs -ljpeg... no checking for rpath... yes checking for KDE... libraries /usr/local/kde/lib, headers /usr/local/kde/includechecking if UIC has KDE plugins available... configure: error: not found - you need to install kdelibs first. root@linux:/usr/src/kdebase-3.1# [/code:1:5a90fe9f1b] kdebase adviseert kdelibs te installeren, terwijl die al geinstalleerd zijn. Namelijk in /usr/local/kde/lib Het lijkt er dus op dat deze output me op het verkeerde been probeert te zetten. Wat mist kdebase nu echt? :roll:
Link naar reactie

6 antwoorden op deze vraag

Aanbevolen berichten

  • 0
//Marcel, de config files van de kdebase-3.1 source laat ik liever ongewijzigd. :roll: //Max,ik heb het volgende geprobeerd met arts-1.1 en kdelibs-3.1 [code:1:133e0c1417] ./configure --prefix=/opt/kde make make install [/code:1:133e0c1417] Maar bij kdebase-3.1 met [code:1:133e0c1417] ./configure --prefix=/opt/kde [/code:1:133e0c1417] De foutmelding die volgde was het zelfde als zonder --prefix=/opt/kde behalve: [code:1:133e0c1417] checking for KDE... libraries /opt/kde/lib, headers /opt/kde/include checking if UIC has KDE plugins available... configure: error: not found - you need to install kdelibs fir$ root@linux:/usr/src/kdebase-3.1# [/code:1:133e0c1417] Dus heb ik uiteindelijk de kdelibs-3.1 van de ftp://ftp.slackware.com/pub/slackware/slackware-current/ gedownload en geinstalleerd met: [code:1:133e0c1417] installpkg kdelibs-3.1-i386-1.tgz [/code:1:133e0c1417] Daarna kon ik kdebase-3.1 wel configureren en installeren met [code:1:133e0c1417] ./configure --prefix=/opt/kde make make install [/code:1:133e0c1417] Geen foutmeldingen deze keer. Aangezien vanuit init 3 [code:1:133e0c1417] startkde [/code:1:133e0c1417] niet werkte [code:1:133e0c1417] jolo@linux:~$ startkde xsetroot: unable to open display '' [/code:1:133e0c1417] heb ik in ~/.xinitrc [code:1:133e0c1417] exec /usr/bin/wmaker $NOCPP [/code:1:133e0c1417] gewijzigd in [code:1:133e0c1417] exec /opt/kde/bin/startkde $NOCPP [/code:1:133e0c1417] om kde te kunnen starten met: startx Het werkt! :D Marcel, Max en Danieldk bedankt voor de reacties, KDE-3.1 ziet er goed uit :)
Link naar reactie

Doe mee aan dit gesprek

Om te reageren, moet je eerst inloggen. Dit doe je door rechtsboven op inloggen te klikken.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...