Ga naar inhoud
  • 0

TV-Kaart


anoniem

Vraag

Hoi allemaal, Ik heb een tv-kaart gekocht, maar software voor het ding is nogal moeilijk te vinden. Ik heb alle modules geinstalleerd, een stuk of 5 en heb geprobeerd xawtv en kwintv te installeren. xawtv geeft bij make een vage erro en kwintv heeft qt2 nodig, dus niet qt3. Weet iemand een goed programma, gebaseerd op qt3 of iets anders recentelijks?
Link naar reactie

Aanbevolen berichten

  • 0
ff draadje omhoog schoppen (SCHOP!!!, bij deze) Goed ik heb nog even serieus de error-log (nou ja die is er niet, configure doet ie prima maar bij make gaat ie in de fout) en xawtv gebruikt LessTif om een User INterface te maken. Ik heb ook ff in de source rondgesnuffeld (tja ik ben nooit bang) en hij zoekt naar een dir Xm waar allerlei handige functies in staan, die hij niet kan vinden. Alles staat wel op schijf maar de include dir kan dus niet gevonden worden. Met welke optie van gcc kan ik die include dir er ff bij zetten? Of is er een centrale configfile waarin ik dat regelen?
Link naar reactie
  • 0
Nee, dat bedoel ik niet, misschien had ik het wat onduidelijk geformuleerd. Die heb ik natuurlijk wel geinstalleerd. Hij kan de include dir van LessTif niet vinden. Dit is een opensource motif clone. Die dir is /usr/X11R6/Xm/include. Xawtv gebruikt functies uit die include dir, in de source staat ook [code:1:aae2ae9760]#include <Xm/xmString.h[/code:1:aae2ae9760] Maar gcc kan die dir niet vinden. Dus zal ik ergens /usr/X11R6 in mijn compile path van gcc of iets dergelijks toe moeten voegen. Maar hoe doe ik dat?
Link naar reactie
  • 0
[quote:89760851cc="w.roosenburg"]Hij kan de include dir van LessTif niet vinden. Dit is een opensource motif clone. Die dir is /usr/X11R6/Xm/include. [/quote:89760851cc] Ten eerste weet je zeker dat je dat niet andersom bedoelt. Dus /usr/X11R6/include/Xm Die dir die jij noemt bestaat ook niet in Slackware 8.1 op mijn PC. 8) Ten tweede, heb je misschien wat meer output, zoals distro + versie, xawtv versie, wat voor een tv-kaart, lspci -tv output, lsmod en dmesg | grep bttv :roll:
Link naar reactie
  • 0
Jolo je had gelijk wat die dir betreft. Overigens heb ik slackware 9.0 beta. Verder krijg ik dit soort meldingen bij make (./configure verloopt probleemloos): [code:1:917db61fe4] x11/motv.c:23:19: Xm/Xm.h: No such file or directory x11/motv.c:24:26: Xm/XmStrDefs.h: No such file or directory [/code:1:917db61fe4] Ik heb LessTif al geinstalleerd (die had ik ook al) en ik heb alle header files op mijn systeem staan: Output van locate (een paar maar): [code:1:917db61fe4] /usr/X11R6/include/Xm/Xm.h /usr/X11R6/include/Xm/XmStrDefs.h [/code:1:917db61fe4] Blijkbaar kan hij de headers niet in die dir vinden, dus hoe voeg ik nu die Path toe? Ik heb al overal gezocht maar ik kon net dat ene ding niet vinden. Er weet toch wel iemand hoe hij basedirs voor include paden aan gcc door kan geven?
Link naar reactie
  • 0
Even kijken Ten eerste, waarom staan ze nog niet in het zoekpad? als je onder een gebruikersaccount als root inlogt, dan heb je op sommige systemen het 'probleem' dat er geen paden zijn ingesteld. Dat kan een oorzaak zijn. Hoe voeg je iets toe aan het zoekpad? Simpel export PATH = $PATH:/zoekpad1/ /zoekpad2/ etc.. Correct me if I'm wrong :) Max
Link naar reactie
  • 0
Een reden van het probleem kan zijn dat je via [b:01cec7ab01]su[/b:01cec7ab01] root bent geworden. Bij sommige distro's wordt er, als je via [b:01cec7ab01]su[/b:01cec7ab01] root wordt, geen PATH ingesteld, en kun je idd bepaalde bibliotheken niet vinden bij het uitvoeren van commando's. Misschien is dat het? Max
Link naar reactie
  • 0
Max je had gelijk ! :) Ik was inderdaad als root ingelogged via su, ik had echter wel de $PATH optie bewerkt, maar dan zal het daar ergens wel zijn misgegaan. Goed, ik ben weer een ergernis armer. Ik krijg nu wat andere meldingen bij het opstarten, maar dan kom ik wel uit denk ik, anders schop ik deze draad wel weer omhoog :D
Link naar reactie
  • 0
Goed, nieuw probleem. Ik heb xawtv dus gecompileerd, maar bij het openen zegt ie: [code:1:7661cf7c1f] can't open /dev/video0: No such file or directory v4l-conf had some trouble, trying to continue anyway v4l2: open /dev/video0: No such file or directory v4l2: open /dev/video0: No such file or directory v4l: open /dev/video0: No such file or directory [/code:1:7661cf7c1f] er is ook geen device video in /dev. Echter doe ik cat /proc/video/dev/video() krijg ik netjes te zien: [code:1:7661cf7c1f] bash-2.05b$ cat /proc/video/dev/video0 name : BT878(Pinnacle PCTV Studio/Ra) type : VID_TYPE_CAPTURE|VID_TYPE_TUNER|VID_TYPE_TELETEXT|VID_TYPE_OVERLAY hardware : 0x1 [/code:1:7661cf7c1f] Dus hij is wel aanwezig. Ik heb ook alle noodzakelijke modules geladen, output van mijn lsmod: [code:1:7661cf7c1f] Module Size Used by Tainted: P NVdriver 1065376 10 (autoclean) usb-ohci 17320 0 (unused) ehci-hcd 13224 0 (unused) usbcore 55136 1 [usb-ohci ehci-hcd] tuner 8768 1 (autoclean) tvaudio 11356 0 (autoclean) (unused) bttv 63776 0 (unused) videodev 5472 2 [bttv] i2c-algo-bit 6696 1 [bttv] i2c-core 12196 0 [tuner tvaudio bttv i2c-algo-bit] btaudio 10252 1 emu10k1-gp 1288 0 (unused) gameport 1516 0 [emu10k1-gp] ne2k-pci 5280 1 8390 5696 0 [ne2k-pci] emu10k1 53896 3 ac97_codec 9608 0 [emu10k1] sound 52980 0 [emu10k1] soundcore 3300 10 [btaudio emu10k1 sound] [/code:1:7661cf7c1f] Ok, ook nog eens output van dmesg | grep bttv [code:1:7661cf7c1f] bttv: driver version 0.7.91 loaded bttv: using 2 buffers with 2080k (4160k total) for capture bttv: Host bridge is PCI device 1039:0646 (Silicon Integrated Systems [SiS]) bttv: Bt8xx card found (0). bttv0: Bt878 (rev 17) at 00:06.0, irq: 9, latency: 32, memory: 0xe6004000 bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012 bttv0: using: BT878(Pinnacle PCTV Studio/Ra) [card=39,autodetected] bttv0: i2c: checking for MSP34xx @ 0x80... not found bttv0: miro: id=31 tuner=4 radio=no stereo=no bttv0: i2c: checking for MSP34xx @ 0x80... not found bttv0: i2c: checking for TDA9875 @ 0xb0... not found bttv0: i2c: checking for TDA7432 @ 0x8a... not found bttv0: i2c attach [client=NoTuner,ok] bttv0: registered device video0 bttv0: registered device vbi0 [/code:1:7661cf7c1f] Conclusie: hij zegt hier ook registered device video(). Echter hij staat niet in /dev directory maar ik kan wel informatie erover opvragen via /proc. Hoe krijg ik nu xawtv werkend? Wat is die meuk van die tv-kaarten slecht gedocumenteerd zeg. Meestal ben ik wel gewend zelf te zoeken maar dit slaat ff alles. Ben al 2 dagen bezig, da's sinds een jaar niet meer voorgekomen geloof ik :)
Link naar reactie

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.

Gast
Antwoord op deze vraag...

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

×
×
  • Nieuwe aanmaken...